Deleting a Data Source after sorting deletes the wrong one

Bug reports.
solovengo
Posts: 24
Joined: Mon Dec 19, 2011 8:14 pm

Deleting a Data Source after sorting deletes the wrong one

Post by solovengo » Fri Jul 12, 2013 10:39 pm

Hello,
I am using Ranorex 4.0.4. I've run into an issue with deleting Data Sources after sorting. I have numerous data sources, and all of them are Simple Data Connectors. If I click the "Manage Data Sources" button in the Test Suite, and I sort them by the "Data Source Name" column, it makes it easier to find them. But if I select a Data Source after sorting, and then I click the Delete button, it appears to have been deleted. However in Source Control, when I compare the Latest vs. Workspace source files, the expected Data Connector was not deleted. The wrong Data Connector is deleted. It appears that if I do not sort the Data Sources, then the correct one will be deleted.

Let me know if you need more info to recreate the issue.

Thank you.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11710
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Deleting a Data Source after sorting deletes the wrong one

Post by Support Team » Tue Jul 16, 2013 9:57 pm

Hello,

Unfortunately I cannot reproduce the issue.
Could you give me a more detailed description in order to reproduce the behavior?
Are you using SVN or TFS? Which version is used?
Have you already read the section "Source Control" in our user guide?
You will find some hints how to use source control in connection with Ranorex there.
Thank you!

Regards,
Bernhard
.
Image

solovengo
Posts: 24
Joined: Mon Dec 19, 2011 8:14 pm

Re: Deleting a Data Source after sorting deletes the wrong one

Post by solovengo » Wed Jul 17, 2013 5:43 am

I am using TFS. And... Yes, I have read the User Guide regarding Source Control. But I don't think Source Control has anything to do with this issue. The only reason I mentioned comparing the source files in Source Control is becasue that proved to me that the wrong Data Connector was deleted.

I am not sure why you are not able to reproduce the issue, because I can easily recreate it.

My environment is as follows:
Ranorex Version is 4.0.4
Visual Studio and TFS versions are 2012
I have 149 Simple Data Connectors created in the Test Suite (95% of them are in use).

Steps to recreate the issue:
1. In the Test Suite, click the "Manage Data Sources" button.
2. In the "Manage Data Sources" dialog, click the "Data Source Name" column header to sort it.
3. Select a Data Source in the list.
4. Click the "Delete" button.

EXPECTED RESULT:
The selected Data Source is deleted. This should be verifiable by comparing the local workspace Test Suite file to the checked-in Test Suite file. The difference should show the expected Data Source was deleted.

ACTUAL RESULT:
The selected Data Source in the "Manage Data Sources" appears to have been deleted. However, if I compare the local workspace Test Suite file to the checked-in Test Suite file, I see that the wrong Data Source was deleted.

If you would like to setup a Live Meeting to view this behavior, let me know. I would be happy to assist in demo'ing the issue.

Thanks!

User avatar
Support Team
Site Admin
Site Admin
Posts: 11710
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Deleting a Data Source after sorting deletes the wrong one

Post by Support Team » Thu Jul 18, 2013 4:39 pm

Hello,

Thank you for the detailed description.
I was able to reproduce the issue now. I will add this issue into our bug tracking system and the responsible developer will fix the bug as soon as possible.
Thank you!

Regards,
Bernhard
.
Image