device is not found in the list of endpoints

Mobile Testing, Android App Testing.
g.madlmayr
Posts: 2
Joined: Wed Nov 22, 2017 10:59 am

device is not found in the list of endpoints

Post by g.madlmayr » Mon Jun 22, 2020 4:09 pm

We have installed Ranorex 9.1.0 on a remote server.

As we have some new apps we want to test I have connected a Samsung Galaxy S7 via USB to my local machine, installed the service app and did the changes for developer options and entered the RDP allowing to use the mobile within the remote session.

But within the session the mobile device is not found.
When I start Ranorex and add an endpoint, the mobile device is not listed.

So my questions:
Is it possible to do mobile testing on a remote machine?
If yes (I hope so), what do I have to do to connect to the mobile device?

I also tried with the IP-Adress but got a status "error" instead of "connected".

User avatar
N612
Posts: 135
Joined: Mon Jul 11, 2016 4:01 pm

Re: device is not found in the list of endpoints

Post by N612 » Mon Jun 22, 2020 7:22 pm

I have done some remote testing on mobile devices but I believe I use a different configuration than you. My remote machine runs Ranorex and has the devices connect to it. I simply connect to that remote machine and use Ranorex on that remote machine, the same machine that the devices are connect to (USB connection).

In theory, the devices can be plugged in anywhere and you can connect to them as a WiFi endpoint as long as they are on the same network and can communicate with your machine over ports 31000 TCP & UDP.

g.madlmayr
Posts: 2
Joined: Wed Nov 22, 2017 10:59 am

Re: device is not found in the list of endpoints

Post by g.madlmayr » Tue Jun 23, 2020 1:28 pm

Thanks for your advice.
We added a rule for TCP port and UDP port 31000.
and additionally found out, that in my homeoffice I am not connected with the companies WLAN-network.

so when my mobile and the remote server were in the same network, the device was immediately found in the list of endpoints.
So problem solved.