Difference in Xpaths in version 8.0 vs version 9.0

Ask general questions here.
navya28
Posts: 17
Joined: Fri May 29, 2015 6:15 pm

Difference in Xpaths in version 8.0 vs version 9.0

Post by navya28 » Mon Oct 26, 2015 6:08 pm

Hello Support,

Are the xpaths different for iOS version 8.0 vs version 9.0 for the iOS Simulator.
Some of the accessibility labels are missing in version 9.0.
Can you suggest me any solution for this.
I did try to add accessibility labels in the ranorex project but could not make it work reliably.

Thanks

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Difference in Xpaths in version 8.0 vs version 9.0

Post by odklizec » Tue Oct 27, 2015 8:15 am

Hi,

As far as I remember, there has been done a lot of optimization and cleanup in iOS9, so changed xpaths could very well be a side effect of this optimization effort? Anyway, it would be helpful if you could post a Ranorex snapshot of the same problematic element, taken from iOS8 and iOS9.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

navya28
Posts: 17
Joined: Fri May 29, 2015 6:15 pm

Re: Difference in Xpaths in version 8.0 vs version 9.0

Post by navya28 » Wed Oct 28, 2015 6:19 pm

Hello Support,

I upgraded to xcode 7.1 and added the accessibility labels in RxBrowser project. It seems to work fine now.
I can see the accessibility labels.

Thank you

navya28
Posts: 17
Joined: Fri May 29, 2015 6:15 pm

Re: Difference in Xpaths in version 8.0 vs version 9.0

Post by navya28 » Wed Oct 28, 2015 6:58 pm

Hello Support,

The accessibility labels are not consistent. Sometimes, I see the labels while other times I dont. I am attaching the snapshots.

Thanks
Attachments
Version 9.1, Go Button.rxsnp
Version 9.1
(11.13 KiB) Downloaded 47 times
Version 8.1, Go Button.rxsnp
Version 8.1
(12.12 KiB) Downloaded 41 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Difference in Xpaths in version 8.0 vs version 9.0

Post by Support Team » Tue Nov 03, 2015 10:03 am

Hi navya28,

Unfortunately we are not aware of such an issue. Our QA department tested several applications (inclusive our RxBrowser project) on different iOS versions and in all scenarios the AccessibleLable was set correct.
May I ask you if this problem also occurs on other applications?

Regards,
Markus (S)
.
Image

navya28
Posts: 17
Joined: Fri May 29, 2015 6:15 pm

Re: Difference in Xpaths in version 8.0 vs version 9.0

Post by navya28 » Thu Dec 17, 2015 11:03 pm

Hello Marcus,

I tried again and I didnt see the accessibility labels in iPhone Simulator, version 9.1. This happens on both iPhone as well as iPad.

Thank you

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Difference in Xpaths in version 8.0 vs version 9.0

Post by Support Team » Mon Dec 21, 2015 1:35 pm

Hi navya28,

Since we were not able to reproduce this behavior on our side I'd like to get in touch with you personal.
Therefore, please send an email to [email protected].

Thank you for your understanding.

Regards,
Markus (S)
.
Image