Documentation for Requirments has wrong links

Bug reports.
PatrickGruber
Posts: 5
Joined: Fri Nov 18, 2016 3:02 pm

Documentation for Requirments has wrong links

Post by PatrickGruber » Fri Nov 18, 2016 3:17 pm

Hi Ranorex,
I just wanted to install on my clean machine all requirements for Ranorex 5.4.4 which I could find here in the docs.

When I downloaded and installed the listed software clicking on the links, Ranorex still said it requires following packages:
- Microsoft Visual C++ 2008 (x64) Redistributable Package
- Microsoft Visual C++ 2008 (x86) Redistributable Package

Then, I have compared the versions installed by Ranorex and the versions from the links and found out they are different. Ranorex requires from the above mentioned packages v9.0.30729.6161

After some research I could find the download link for that specific version and this solved the issue. Since I'm a "new" user I can NOT post links and therefore I am not allowed to post here the correct link for these packages.

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Documentation for Requirments has wrong links

Post by krstcs » Mon Nov 21, 2016 5:32 pm

First, and foremost, Ranorex 5.4.4 is long out-of-date and is no longer supported. Please update to a current version (6.0.2 and 6.1.1 are currently supported).

Second, if you install Ranorex (even 5.4.4) on a clean system using the official installer (Ranorex-6.1.1.exe), it will attempt to install all prerequisites for you, so you should not need to install the VC++ redistributables manually (and I would not recommend it).
Shortcuts usually aren't...