Does repo variable helps in cross browser testing?

Ask general questions here.
Dinesh27
Posts: 3
Joined: Wed Jun 15, 2016 8:03 am

Does repo variable helps in cross browser testing?

Post by Dinesh27 » Thu Jun 16, 2016 10:42 am

Hi All,
I have recorded actions in firefox like (clicking,selection stuff like that).. when I run it in firefox,things are fine..but when I am trying to run it in chrome or IE it just opens the browser with the specified url and no action takes place.

how to stabilize this? I wanna record an action in a particular browser and run it through different browser.. Thanks in Advance! :) :)

Thanks & Regards,
Dinesh

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3921
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Does repo variable helps in cross browser testing?

Post by odklizec » Fri Jun 17, 2016 7:40 am

Hi Dinesh,

It's pretty hard to tell what's wrong without more details about your problem.Please answer the following questions:

Is there any error visible in report?

Are you sure both chrome and IE are correctly instrumented to work with Ranorex (there must be installed and enabled Ranorex plugin)?

What Ranorex version do you use?

Have you checked if the xpaths recorded in FF are working in Chrome and IE? You see, in an ideal world, xpaths recorded in one browser would work in all browsers. Sadly, we don't live in ideal world and some xpaths may need to be edited to make them work in all browsers. This is what you always need to do after each recording session.

Please post the xpath of element for action, following the browser start. Ideally, post entire solution or at least a sample solution created for example with Ranorex web. Or do you have problem with just the web you need to test?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration