DOM Document not found

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
pere
Posts: 12
Joined: Mon May 25, 2009 3:32 pm
Location: Barcelona

DOM Document not found

Post by pere » Fri Jul 17, 2009 3:18 pm

Hi,
I'm using Ranorex to automate a quite simple process that has to be performed with a Web Application. The application I've build is always running, and each time it has to perform that specific process, it:
1.- Launches a new IE browser
2. Performs the operations
3.- Closes the browser
This is working perfectly, but after several days of work, suddenly the Ranorex API does not work anymore, because after launching an IE process I cannot retrieve the DOM document from IE. Restarting the application does not have any effect, and I need to reboot the machine to be able to work again.
So, after 3-5 days of work, I have to reboot the machine. Does anybody have any idea about what can be happening?
Thanks!

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: DOM Document not found

Post by Support Team » Mon Jul 20, 2009 9:58 am

Hi pere,
please could you give a more detailed description of your purpose.
period of calling the web automation?
which operations to you perform in IE?
IE version?

Regards,
Christian
Support Team
.
Image

pere
Posts: 12
Joined: Mon May 25, 2009 3:32 pm
Location: Barcelona

Re: DOM Document not found

Post by pere » Mon Jul 20, 2009 10:53 am

Sure! The IE version I'm using is IE8. The application is working almost continuously. What it does is login into a internal web application and perform some deletion of information. During this process the Ranorex API is used to navigate to some pages, fill in some forms, and delete some data from other forms. Sometimes additional windows are opened and closed during the process. If there's an error during this process, a window could be left open. This is why at the start of each deletion operation the application ensures that no IE browsers are left open (the existing explorer processes, if any, are killed). I don't dare to close the open IE windows using Ranorex because sometimes a popup confirmation window is shown, and if I use Ranorex to click the OK or Cancel button, the calling thread gets locked in the call (actually this happens during my automated deletion process, and I have an additional thread to look for these confirmation windows and press the OK button using the keyboard).
The complete process lasts for about 2-3 minutes. When completed, it starts again with a new deletion operation and a new browser.
After some days, I cannot retrieve the DOM document anymore unless I restart the machine. No dumb explorer processes or whatever are running...

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: DOM Document not found

Post by Support Team » Mon Jul 20, 2009 11:30 am

At the moment we are trying to reproduce this issue. I hope we are able to find the problem shortly and if it`s Ranorex specific to fix it until next bugfix release.

Regards,
Christian
Support Team
.
Image