Elements are not highlighting when launching Ranorex with Administrator

Bug reports.
Subburaj
Posts: 4
Joined: Fri Oct 18, 2019 8:45 am

Elements are not highlighting when launching Ranorex with Administrator

Post by Subburaj » Thu May 07, 2020 5:45 pm

Elevated permissions required.png
Elevated permissions required.png (14.25 KiB) Viewed 208 times
Hi all,

I want to debug the code in the Ranorex Studio 9.2.0, after enabling the debugger mode, it confirms for administrator and after clicking YES button, the Ranorex Studio launch with Administrator rights.

==Issue
Scripts is not running in the debugger mode, since elements in the repository is not highlighting due to launch with Administrator rights

Any help would be appreciated!


Note:
[Warn ][WPF.Core]: UI elements in your 'WPF.Core' AUT can't be identified because it couldn't be instrumented automatically. Restart all Ranorex tools and the AUT with the same privileges, preferably as an administrator.
Could not set-up managed injection endpoint: DotNet Core CLR bootrapping error
Process: 'Test.Automation' (pid 12472)
(This message is only shown once per report.)

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6280
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Elements are not highlighting when launching Ranorex with Administrator

Post by odklizec » Mon May 11, 2020 7:07 am

Hi,

I'm afraid, that this kind of issue cannot be solved without access to the app under test. I think you will have to contact Ranorex support and request a remote session with them, so they can analyze the problem on your machine.

All I can suggest is, that you should update Ranorex with most recent 9.3.1 and check if the problem is still present? Version 9.2.0 is obsolete and no longer supported and there fwere many bug fixes introduced between 9.2.0 and 9.3.1. Also, make sure that the app under test is whitelisted in Ranorex.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration