Elevated Permission required Pop up

Ranorex Spy, Recorder, and Studio.
Kiruthika
Posts: 5
Joined: Tue Jan 02, 2018 1:45 pm

Elevated Permission required Pop up

Post by Kiruthika » Thu Jan 04, 2018 12:17 pm

Hi Team,

I have installed Ranorex 5.4.3 in Windows 10 machine and when I try to run the test case from Ranorex Studio, I am getting pop up as "Elevated Permission required" (Message in pop as: "The Process to debug runs with higher Privilege. Ranorex Studio needs to be restarted as Administrator. )

How to disable this pop up ?

Regards,
Kiruthika

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Elevated Permission required Pop up

Post by krstcs » Thu Jan 04, 2018 3:02 pm

You have two options if you are debugging in Windows 10, both of which require you to have local admin rights on your system.

1. Turn off UAC in Windows 10.
or
2. Start Ranorex as administrator.

Otherwise, you can turn off debugging mode and run normally, if you don't need to actually debug.

Debugging requires admin rights on the local system, this is a Windows/.NET security issue.
Shortcuts usually aren't...

Kiruthika
Posts: 5
Joined: Tue Jan 02, 2018 1:45 pm

Re: Elevated Permission required Pop up

Post by Kiruthika » Thu Aug 02, 2018 11:36 am

Hi Team,

I have Ranorex 8.0.1 and when I try to run the automation script in debug mode, I am getting "Elevated Permission required Pop up"

Recently OS upgraded to Win 10 (1709), can you please suggest me the solution.

Note: I don't have Admin rights as per organization policy

Regards,
Kiruthika

asdf
Posts: 174
Joined: Mon Mar 21, 2016 3:16 pm

Re: Elevated Permission required Pop up

Post by asdf » Thu Aug 02, 2018 12:48 pm

Hi,

You can use the debugger without administrator rights, by simply disabling the UIALauncher in the Ranorex Settings.
Settings.png
Settings.png (10.71 KiB) Viewed 280 times
I hope that helps.
asdf