Elevated Permissions Required

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
floolf
Posts: 12
Joined: Thu Nov 19, 2015 1:49 pm

Elevated Permissions Required

Post by floolf » Thu Jan 18, 2018 6:22 pm

Hello,

I am developping tests on a Win32 application.
I once developed tests on a previous version of the same application in Ranorex 6.x
I used a new solution with Ranorex 7.2, but tried to reuse some of my old repository ( I copy/pasted some element from the old solution to the new one)
Since both the application and WPF plugin changed, my old objects did not work.
I created new ones, but I have troubles with WPF recognition : Ranorex displays its warning and sometimes my objects are found sometimes not, sometimes reference in a non WPF tree are returned ....
I don't understand the trouble shooting message for WPF. My application in Win32, in my settings, Bridge 32/64 is enabled, WPF Legacy/UIA Interaction is WpfImprovedOnly

I tried to upgrade Ranorex to 8.0 ( and migrated my solution). But now, when I launch my tests, Ranorex requires Elevated Permissions.
I tried to accept Elevated permissions, but then my application refuses to connect ( It refuses to connect when runned as Adminitrator)
When I refuse Elevated permissions, Ranorex refuses to execute my tests

What should I do ?

Thank for your answer




Thanks in advance

asdf
Posts: 174
Joined: Mon Mar 21, 2016 3:16 pm

Re: Elevated Permissions Required

Post by asdf » Wed Jan 24, 2018 3:30 pm

Hi floof,

It really sound to me like you are trying to run your tests with enabled debugger. Since the debugger needs administrator privileges, I would suggest turning it off and execute your tests again.
Debugger.png
Debugger.png (1.33 KiB) Viewed 263 times