Enabled Property of Image Buttons

Bug reports.
dal
Posts: 72
Joined: Thu Jun 24, 2010 8:59 am

Enabled Property of Image Buttons

Post by dal » Wed Nov 10, 2010 11:02 am

Hi,

We have an application (C# .Net), in which we have few Image Buttons, based on the data entered on the Web Page it will be Enabled / Disabled.

But with Ranorex Spy both Enabled / Disabled state will be treated as Always Enable. (i.e. Enabled = True)

PFA the Screen-shot for reference...

Regards,
Dal...
Attachments
Sample.zip
Screen-shot for Reference
(158.88 KiB) Downloaded 197 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Enabled Property of Image Buttons

Post by Support Team » Wed Nov 10, 2010 11:32 am

Hi Dal,

Please tell which version of Ranorex is in use at your side. Please also take a look to the HTML code of the web-page and would it be possible to post it?

Thanks in advance.

Regards,
Peter
Ranorex Team
.
Image

dal
Posts: 72
Joined: Thu Jun 24, 2010 8:59 am

Re: Enabled Property of Image Buttons

Post by dal » Wed Nov 10, 2010 11:50 am

Hi Peter,

We are using Ranorex 2.3.4 verion (latest one)

PFA the HTML Code of the web page.

Regards,
Dal...
Attachments
SampleHtmlCode.zip
HTML Code of the Web Page
(13.48 KiB) Downloaded 183 times

dal
Posts: 72
Joined: Thu Jun 24, 2010 8:59 am

Re: Enabled Property of Image Buttons

Post by dal » Wed Nov 10, 2010 12:06 pm

Hi Peter,

PFA the QTP - Object Spy Screen-shot for these buttons.

Regards,
Dal...
Attachments
Disabled Property in QTP.zip
Disabled Property in QTP
(56.05 KiB) Downloaded 190 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Enabled Property of Image Buttons

Post by Support Team » Wed Nov 10, 2010 12:57 pm

Hi,

Have you tried to use the disabled attribute in the RxPath?
input[@disabled='true']
It should be possible to get the attribute, even when it is not suggested by Ranorex.
Please can you try this out.

Thanks in advance.

Regards,
Peter
Ranorex Team
.
Image

dal
Posts: 72
Joined: Thu Jun 24, 2010 8:59 am

Re: Enabled Property of Image Buttons

Post by dal » Thu Nov 25, 2010 8:03 am

Hi Team,

Disabled property is not working as expected, The same issue with SpanTag as well, if the Item is disabled, I am seeing as Enabled = 'TRUE' & Tried with @disabled = 'True', but not working.

It could be great the Ranorex Spy can identify As 'Enabled' = 'False' for Img & Span Tags. If other Tag also giving the same issue, kindly fix this.

Regards,
Dal...

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Enabled Property of Image Buttons

Post by Support Team » Thu Nov 25, 2010 11:03 am

Hi,

I've tried it out by myself with your sample code and it worked as expected with "input[@disabled='True']".
It also worked fine with span and image tag for me.
Probably you have used 'true' instead of 'True' and that was the problem.

I hope that was the problem and it works fine for you now.

Regards,
Tobias
Support Team
.
Image