Ensure Visible by default

Ask general questions here.
erman
Posts: 15
Joined: Tue May 15, 2012 3:53 pm

Ensure Visible by default

Post by erman » Fri Mar 22, 2013 10:25 pm

Hi,

We are seeing some performance issues when executing our Ranorex tests against a Flex application. The issue is that Ranorex is taking approximately 3 seconds to go from field/control to field/control. This seems way to slow.

I have determined that the only thing that improves this issue is to 'uncheck' the Ranorex global setting for "Use Ensure Visible by Default", however, this causes issues when a field/control is below the visible screen (i.e. need to scroll down).

Has anyone seen this issue? Any recommendations on how to improve the speed of test execution would be greatly appreciated.

Note: We have tried the "Mouse.DefaultMoveTime" and "Delay.SpeedFactor" settings, but these did fix the issue.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ensure Visible by default

Post by Support Team » Mon Mar 25, 2013 4:58 pm

Hello,

Thank you for reporting this issue.
In order to analyze this behavior in more detail, we would need more information. Is it possible to send us your solution and access to your application? Which version of Ranorex are you using?
Does the issue also occur when you test another application than your flex application?
Could it be a problem with the search timeout of the specific Repository item?
Thank you!

Regards,
Bernhard
.
Image

erman
Posts: 15
Joined: Tue May 15, 2012 3:53 pm

Re: Ensure Visible by default

Post by erman » Mon Apr 01, 2013 4:50 pm

Thanks for the reponse. I guess we can setting up a live meeting so that the issue can be looked at. We have sent emails to Ranorex Support and we have tried the suggestions, but the problem still exists.

Eric

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ensure Visible by default

Post by Support Team » Tue Apr 02, 2013 3:34 pm

Hello,

Thank you for your response.
We will send you information about a remote session via email.

Regards,
Markus (T)
.
Image