Error in "Send to Repository"

Ranorex Spy, Recorder, and Studio.
fp_philipp
Posts: 7
Joined: Fri Apr 10, 2009 10:43 am

Error in "Send to Repository"

Post by fp_philipp » Tue Apr 21, 2009 8:47 am

I hope, i'm not very annoying :|

I get an error from time to time, but regularly.

The error is like this:
System.ArgumentException: Cannot move entry 'TextText' to folder 'TabPageListTab'.
at Ranorex.Core.Repository.RepositoryFolder.MoveChild(RepositoryEntry child, RepositoryFolder targetFolder)
at Ranorex.Core.Recorder.RepositoryGenerator.BuildGroups(String currentPrefix, List`1 paths, Dictionary`2 elementPathMap, ElementRepository repo, RepositoryFolder curFolder, Configuration config)
at Ranorex.Core.Recorder.RepositoryGenerator.UpdateRepositoryFromRecording(ElementRepository repo, Dictionary`2 pathElementMap, Configuration config)
at Ranorex.Controls.RepositoryEditor.PerformDropDefault(ElementInfo info)
at Ranorex.Tools.SpyForm.elemTree_RequestRepositoryExport(Object sender, EventArgs e)
at Ranorex.Controls.ElementTreeAdv.OnRequestRepositoryExport(EventArgs e)
at Ranorex.Controls.ElementTreeAdv.sendToRepositoryToolStripMenuItem_Click(Object sender, EventArgs e)
at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
After i got this error spy doesn't work correct anymore. When i save my repository now and reopen it, it got some defect, because some elements are missing and others are listened, but i can't move them or do anything else with them until i add them new.
I also can't add the element where the error appeared until i reopen spy, then there is no error anymore...

Could you please help me, because it's very annoying getting this error all the time and hoping that the repository doesn't loose any entries. :(

regards
philipp

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Post by Support Team » Tue Apr 21, 2009 10:39 am

hi philipp,

1) Could you please post the Ranorex version you are using ?
2) Ideally, are there any steps to consistenly reproduce the problem ?


Michael
Ranorex Team

fp_philipp
Posts: 7
Joined: Fri Apr 10, 2009 10:43 am

Post by fp_philipp » Tue Apr 21, 2009 1:52 pm

Hi Michael!

I'm using Ranorex 2.0.1.5691.

Sry but i can't get a way to consistenly reproduce the error :(

and it seems like the bigger my repository grows the oftener the error occures... :cry:

But sometimes i work hours until the error occurs again and sometimes it only takes aprox. 10 min. to get the error again.

The problem is i can't see any connection from one error to the next one. :roll:

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Post by Support Team » Wed Apr 22, 2009 12:44 pm

philipp,

please try to update to version 2.0.2 and check if the error persists.
If it does we will try to fix it for V2.1.0

Michael
Ranorex Team