Error Message @compiling Ranorex Solution

Ask general questions here.
anja
Posts: 67
Joined: Fri Nov 26, 2010 3:39 pm

Error Message @compiling Ranorex Solution

Post by anja » Wed Aug 17, 2011 9:40 am

Hi,

I've got a Ranorex-Solution from a colleague... He worked with VisualStudio 2010.
Now I wanted to compile and execute the tests with Ranorex-Studio (Version 2.3.9 - The version he had used during development).
I got following Error Message:
  • Line 539: The OutputPath property is not set for this project. Please check to make sure that you have specified a valid Configuration/Platform combination. Configuration='Debug' Platform='x86'
The solution contains many projects but for every project the OutputFolder /bin/Debug is set and the configuration/platform is set to the above mentioned values...

Can someone tell me what I have to adapt in this solution?

Thank you

Anja

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Error Message @compiling Ranorex Solution

Post by Support Team » Wed Aug 17, 2011 11:50 am

Hi,

If you want to use your 2.X projects with Ranorex 3.X you have to consider the steps which are mentioned in our User Guide. Therefore please take a look and try to perform all the steps.

Regards,
Markus
Ranorex Support Team
.
Image

anja
Posts: 67
Joined: Fri Nov 26, 2010 3:39 pm

Re: Error Message @compiling Ranorex Solution

Post by anja » Wed Aug 17, 2011 12:02 pm

Hi,
no, I don't wanted to change the version of Ranorex... I use the same version as he had before (2.3.9).
The only difference is, he had used visual studio and I want to compile and start the tests with Ranorex Studio.

Thanks

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Error Message @compiling Ranorex Solution

Post by Support Team » Wed Aug 17, 2011 12:22 pm

Hi,

ah okay, then check if the output path is set. Therefore perform a right click on your Project, in Ranorex Studio, then go to the "Compiling" settings and check if the "Output Path" is set, should be "bin\Debug\" or something like that.

Regards,
Markus
Ranorex Support Team
.
Image

anja
Posts: 67
Joined: Fri Nov 26, 2010 3:39 pm

Re: Error Message @compiling Ranorex Solution

Post by anja » Wed Aug 17, 2011 12:38 pm

Hi,

the Output Path is set for every project in the solution to "bin\Debug\"...
Any other ideas?

Thank you very much...

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Error Message @compiling Ranorex Solution

Post by Support Team » Wed Aug 17, 2011 1:27 pm

Hi,

Have you checked it for each of your projects, because it seems to be that issue?
I have deleted the Output Path in my project and I got the same message, so please check if you have forgotten to set it for one of your projects.

Regards,
Markus
Ranorex Support Team
.
Image

anja
Posts: 67
Joined: Fri Nov 26, 2010 3:39 pm

Re: Error Message @compiling Ranorex Solution

Post by anja » Wed Aug 17, 2011 1:38 pm

the Output Path is set for every project in the solution
Like I've written in my previous posts... the Output Path is set for every project in the solution... I've checked this three times now....

I hope for any other idea.....

Thank you a lot....

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Error Message @compiling Ranorex Solution

Post by Support Team » Wed Aug 17, 2011 2:13 pm

Hi,

Can you send us the whole project, then we will take a look at it?
Please send it to our support E-Mail address: [email protected].

Regards,
Markus
Ranorex Support Team
.
Image

anja
Posts: 67
Joined: Fri Nov 26, 2010 3:39 pm

Re: Error Message @compiling Ranorex Solution

Post by anja » Fri Aug 19, 2011 9:13 am

Hi,

after I've sended the solution to Ranorex-support, Igot following answer:
One of our Testmodules
[...]causes the error, because the Output Path property in the “Compiling” settings was wrong.

To solve this problem you have to add this project to your solution, open the “Compiling” window and click on the button with the point, on the left side of the text field where you can write the “Output Path” in.

You will see that there are two output path properties set instead of one. Therefore please uncheck the “Platform-specific” one.
Now you can rebuild the whole solution and after the rebuild you can delete the file from the solution again.

It seems that the Visual Studio can handle or ignore the specific case.

We will take a look into it and will see if we can fix/handle this case in the Ranorex Studio.
The attached solutions worked correctly...

Thanks for this very fast support!!!