Error messages

Ask general questions here.
User avatar
Vanderson
Posts: 13
Joined: Fri Dec 13, 2019 5:31 pm

Error messages

Post by Vanderson » Mon Feb 17, 2020 3:57 pm

Hello Guys,

Here I am with more one noob question, please be patient with me...

I work with a team and received a Ranorex project form another member (from GIT Repository). The project works fine in my partner machine, but in my machine the project don't work. I received several messages of errors and warnings and I don´t know how to fix it.

And also the objects of project in my machine have "red exclamation points" and I don´t know what means or what is missing (image attached).

My system is:
Microsoft Windows [Version 10.0.17763.973]
Ranorex 9.2.1+git37787e16

Erros Messages:
The primary reference "System.ComponentModel.Annotations, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", which is a framework assembly, could not be resolved in the currently targeted framework. ".NETFramework,Version=v4.6.2". To resolve this problem, either remove the reference "System.ComponentModel.Annotations, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" or retarget your application to a framework version which contains "System.ComponentModel.Annotations, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a".
The primary reference "System.ValueTuple, Version=4.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51", which is a framework assembly, could not be resolved in the currently targeted framework. ".NETFramework,Version=v4.6.2". To resolve this problem, either remove the reference "System.ValueTuple, Version=4.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51" or retarget your application to a framework version which contains "System.ValueTuple, Version=4.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51".
The primary reference "System.ComponentModel.Annotations, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", which is a framework assembly, could not be resolved in the currently targeted framework. ".NETFramework,Version=v4.6.2". To resolve this problem, either remove the reference "System.ComponentModel.Annotations, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" or retarget your application to a framework version which contains "System.ComponentModel.Annotations, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a".
The primary reference "System.ComponentModel.Annotations, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", which is a framework assembly, could not be resolved in the currently targeted framework. ".NETFramework,Version=v4.6.2". To resolve this problem, either remove the reference "System.ComponentModel.Annotations, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" or retarget your application to a framework version which contains "System.ComponentModel.Annotations, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a".
The primary reference "System.ComponentModel.Annotations, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", which is a framework assembly, could not be resolved in the currently targeted framework. ".NETFramework,Version=v4.6.2". To resolve this problem, either remove the reference "System.ComponentModel.Annotations, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" or retarget your application to a framework version which contains "System.ComponentModel.Annotations, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a".
The primary reference "System.ValueTuple, Version=4.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51", which is a framework assembly, could not be resolved in the currently targeted framework. ".NETFramework,Version=v4.6.2". To resolve this problem, either remove the reference "System.ValueTuple, Version=4.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51" or retarget your application to a framework version which contains "System.ValueTuple, Version=4.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51".
The primary reference "System.ComponentModel.Annotations, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", which is a framework assembly, could not be resolved in the currently targeted framework. ".NETFramework,Version=v4.7.2". To resolve this problem, either remove the reference "System.ComponentModel.Annotations, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" or retarget your application to a framework version which contains "System.ComponentModel.Annotations, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a".
The primary reference "System.ValueTuple, Version=4.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51", which is a framework assembly, could not be resolved in the currently targeted framework. ".NETFramework,Version=v4.7.2". To resolve this problem, either remove the reference "System.ValueTuple, Version=4.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51" or retarget your application to a framework version which contains "System.ValueTuple, Version=4.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51".


Thanks in advance for any help.

Vanderson Araujo
Attachments
2020-02-17 14_37_46-webApp - Ranorex Studio - (32bit).png
2020-02-17 14_37_46-webApp - Ranorex Studio - (32bit).png (8.11 KiB) Viewed 130 times
Best Regards,

Vanderson Araujo

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6036
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Error messages

Post by odklizec » Mon Feb 17, 2020 4:15 pm

Hi,

Please make sure that there is installed .Net 4.6.2, or even better 4.7.2 on your system (one of the projects seem references 4.7.2). Additionally, check if your system mets all 9.2 software requirements, described here...
https://www.ranorex.com/help/latest/ran ... uirements/
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

User avatar
Vanderson
Posts: 13
Joined: Fri Dec 13, 2019 5:31 pm

Re: Error messages

Post by Vanderson » Mon Feb 17, 2020 4:30 pm

Hello odklizec,
Thanks for your message.

1 - .NET 4.6.2 SDK, is installed in my system, (cheked in Control Panel);
2 - About if system mets all 9.2 software requiremets in the link, I supposed it´s OK, because the link describe: "They are automatically installed when running the Ranorex Studio setup". My ranorex was intalled by setup, then I don´t know if all requirements was covered by setup.

What can I do?

thanks in advance.

Vanderson Araujo
Best Regards,

Vanderson Araujo

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6036
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Error messages

Post by odklizec » Mon Feb 17, 2020 4:56 pm

Well, yes, setup should automatically install required libs. But in some (unknown) cases, it may not ;) I would suggest to go through the list of required libs and runtimes and try to reinstall them, including .Net (eventually try to install 4.7.2).
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

User avatar
Vanderson
Posts: 13
Joined: Fri Dec 13, 2019 5:31 pm

Re: Error messages

Post by Vanderson » Mon Feb 17, 2020 6:54 pm

Hello odklizec,

I'd checked one by one:
OS: Windows 10 updated - OK
Microsoft Windows Installer 3.1 or higher - Installed
Microsoft Visual C++ 2017 x86 - Can't download from MS. the link to download page don't work today.
Microsoft Visual C++ 2017 x64 (required for 64 bit Windows versions only) - Same over.
Microsoft .NET Framework 4.6.2 or higher - Installed
Internet Explorer 11 or higher (with the latest patches and updates) - I don't use IE, but it's installed on machine if a need to regression tests in 1980 ;-)))

My suspicious could be over Microsoft Visual C++ 2017. I'll try to download and test again.

Thanks in advance.
Best Regards,

Vanderson Araujo