error using Object Repository

Class library usage, coding and language questions.
balajichandan
Posts: 24
Joined: Tue Apr 14, 2009 12:29 pm

error using Object Repository

Post by balajichandan » Thu Mar 11, 2010 12:33 pm

Hi,

I have seen an error in object repository generated by Ranorex Spy and the error is as follows:

2010/03/11 12:39:07.074 ERROR LogExceptionMsg() Ranorex.ElementNotFoundException : Failed to find item 'MenuItemAdd_New' within the specified timeout of 1.5m.

2010/03/11 12:39:07.168 ERROR User at Ranorex.Core.Repository.RepoGenBaseFolder.CreateAdapterForPath[T](String itemName, String path, Duration searchTimeout, Nullable`1 useEnsureVisible) at RanorexTest2x.ObjRepoFolders.ContextMenuMenu1Folder.get_MenuItemAdd_New() in C:\Balaji\RanorexTest2x\ObjRepo.Repository.cs:line 3050 at RanorexTest2x.DMUtility.SelectImportFilesCtxMenuOnDVNode(TreeItem trNode) in C:\Balaji\RanorexTest2x\DMUtility.cs:line 2313 at RanorexTest2x.OtherScenarios.DM13932_VerifyCtxMnuOperationsOnMatterNode() in C:\Balaji\RanorexTest2x\Other Scenarios.cs:line 1490

This throws an exception dialog with title Microsoft .NET Framework. Can I know why is this happening with object repository. By the way, I use Ranorex 2.1.3.

Thanks
Balaji

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: error using Object Repository

Post by Support Team » Fri Mar 12, 2010 11:59 am

Hi Balaji,

it's seems that that the item 'MenuItemAdd_New' not exists. Ranorex throw following error "Failed to find item 'MenuItemAdd_New' within the specified timeout of 1.5m. ", beacuse it cannot find the specific item.

And you get an .Net Framework Error, mabye no try catch block is around your code.

Regards,
Peter
Ranorex Support Team
.
Image