Error when running selected actions from a module

Bug reports.
cerkvenic
Posts: 3
Joined: Mon Nov 13, 2017 8:23 am

Error when running selected actions from a module

Post by cerkvenic » Mon Nov 13, 2017 8:39 am

How to reproduce
40% of all times, when manually starting selected action, the error below appears and the actions are not started.

Error
Cannot start process. Zugriff verweigert (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

Environment
Ranorex Version: 7.1.1
OS: Windows 10

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3921
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Error when running selected actions from a module

Post by odklizec » Mon Nov 13, 2017 9:34 am

Hi,

Unfortunately, without knowing more details about your test and AUT, there is not much anyone here can do or suggest. Any chance you can post your solution and AUT (or at least a shareable sample of both test and AUT)?

Additionally, Ranorex 7.1.1 is already few months (and 4 versions) old, so I would suggest to update with most recent 7.2.1 and see if the problem exists in this version as well. I'm sure this is something Ranorex folks would request too ;) And finally, please make sure you are running your test as Administrator and from LOCAL drive and not shared network drive! Ranorex does not recommend/support running tests from network drive, because it may impact stability and overall performance of tests.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration