Error when trying to install browser extensions

Ask general questions here.
zdog454
Posts: 3
Joined: Mon Jun 26, 2017 2:55 pm

Error when trying to install browser extensions

Post by zdog454 » Mon Jun 26, 2017 3:14 pm

I am currently working remotely connected to Windows Server 2012 R2 with Ranorex 7.0.1 and a floating license installed on the machine.

When I try to install and/or enable the browser extension for Chrome, I get a pop-up window that says "Ranorex.Plugin.ChromeMsgHost has stopped workking". I've tried this on Firefox as well and get the same type of pop-up.

I initially ran my test on a Windows 8 machine and did not run into this issue when installing the extensions.
Attachments
HostError.PNG
Image of the pop-up I see for Chrome
HostError.PNG (61.6 KiB) Viewed 603 times

McTurtle
Posts: 191
Joined: Thu Feb 23, 2017 10:37 am
Location: Benedikt, Slovenia

Re: Error when trying to install browser extensions

Post by McTurtle » Tue Jun 27, 2017 10:12 am

Hello zdog454,

It would be interesting to see the FUSLOGVW.exe log: Fuslogvw.exe (Assembly Binding Log Viewer)

If you don't have it, then you need to install the Windows SDK.

When you start Google Chrome then the following entry should be visible in the binding log viewer.
BindingLogViewer.png
BindingLogViewer.png (11.88 KiB) Viewed 592 times
In my case of course there is a success reported. In your case you should be able to find some useful information there. Can you post the log in this forum thread?

Regards,
McTurtle

zdog454
Posts: 3
Joined: Mon Jun 26, 2017 2:55 pm

Re: Error when trying to install browser extensions

Post by zdog454 » Tue Jun 27, 2017 2:58 pm

Hi McTurtle,

When I run fuslogvw and start Chrome with the Ranorex extension enabled, I get a decent amount of logs from ChromeMsgHost. I attached an image of the fuslogvw view and one of the logs.

When I look through the logs individually, they all say that their operation was successful.
Attachments
Fuslogvw_Log_Example.PNG
Fuslogvw_Log_Example.PNG (62.14 KiB) Viewed 583 times
Fuslogvw_Picture.PNG
Fuslogvw_Picture.PNG (45.47 KiB) Viewed 583 times

McTurtle
Posts: 191
Joined: Thu Feb 23, 2017 10:37 am
Location: Benedikt, Slovenia

Re: Error when trying to install browser extensions

Post by McTurtle » Wed Jun 28, 2017 12:45 pm

Hello zdog454,

Could you also post the details of the error message?
Also, please check in the Windows Event Log if there is an entry concerning this crash and post it in this thread.

Furthermore, have you already tried a clean reinstall of Ranorex?

Regards,
McTurtle

zdog454
Posts: 3
Joined: Mon Jun 26, 2017 2:55 pm

Re: Error when trying to install browser extensions

Post by zdog454 » Wed Jun 28, 2017 2:22 pm

I feel dumb. I didn't think about trying to reinstall Ranorex first 8) .

I downloaded the zip folder first time so I decided to install the .exe this time and it worked like a charm. I think the problem was that the installer I used in the zip didn't alert me to some of the things I was missing on the server (Visual C++ Distributions).

It does explain somethings because before I tried to reinstall, I looked in the Event Viewer and didn't see any reports for any errors related to Ranorex.

Thank you for helping me McTurtle. I appreciate it.