Errors with Ranorex 5.3.4

Ask general questions here.
jackrabbit
Posts: 47
Joined: Wed Mar 18, 2015 10:06 pm

Errors with Ranorex 5.3.4

Post by jackrabbit » Mon Feb 15, 2016 10:56 pm

Because I had problems with Ranorex, tech support recommended I uninstall / reinstall VC++ Redistributable package. I did it but now I have more problems than before:

1) When I start Ranorex from the shortcut on the desktop, I get this error:
2016-02-15_16h56_05.png
2016-02-15_16h56_05.png (43.96 KiB) Viewed 542 times
2) When I try to compile my solution, I get this error:
2016-02-15_16h58_28.png
2016-02-15_16h58_28.png (9.94 KiB) Viewed 541 times
I tried to install the Framework 4, but Windows blocked me because I already had a more recent version installed (4.6.1), so I uninstalled Framework 4.6.1, I re-installed FRamework 4.0, then I re-installed Framework 4.6.1, but now it no longer shows FRamework 4.0 as being installed, and I still get the Ranorex error when I compile.

I am stuck!

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Errors with Ranorex 5.3.4

Post by odklizec » Wed Feb 17, 2016 9:13 am

Hi,

Uninstalling VC++ Redistributable package is not a very good idea, because Ranorex requires it. Have you tried to uninstall and reinstall Ranorex?

Also, what problems exactly you experienced with Ranorex (before you tried to uninstall VC++ redist. package)? The same problem as shown on the attached screenshot?

Please keep in mind that Ranorex 5.3.4 is a very old and no longer supported version. I would suggest to try to install latest 5.4.5 (even in trial mode) to see if the problem gets fixed.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration