ExcelConnector Issue

Ranorex Spy, Recorder, and Studio.
VinRoxx
Posts: 5
Joined: Sun Jun 07, 2015 6:31 pm

ExcelConnector Issue

Post by VinRoxx » Sun Jun 07, 2015 6:53 pm

Hello Everyone,

I am new to Automation and Ranorex tool both and Ive been following the user guide religiously but unable to resolve the issues which Ive come across for Excel Connector in Data driven testing

Screenshot attached. I have tried with all possible formats and version of excel and ms office respectively but this error does not seem to get resolve

Please help as I want to finish this training for a new opportunity

Thanks
Attachments
ExcelConnector Issue.png
ExcelConnector Issue.png (14.45 KiB) Viewed 744 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: ExcelConnector Issue

Post by Support Team » Mon Jun 08, 2015 4:08 pm

Hi VinRoxx,

Are you sure you installed the full version or Excel and not just the Excel Viewer, for instance?
If so, please try to reinstall Ranorex. Uninstall Ranorex, restart your machine and install Ranorex with the Ranorex-X.exe again.
Please do let us know if that fixed the issue.

Regards,
Markus
.
Image

VinRoxx
Posts: 5
Joined: Sun Jun 07, 2015 6:31 pm

Re: ExcelConnector Issue

Post by VinRoxx » Mon Jun 08, 2015 6:49 pm

Hello Markus,

I have installed full version of Office 2010 Professional, prior to it I had MS Office 2013 Pro full edition. I have also installed OpenOffice to see if non .xls or .xlsx type would be supported by Ranorex of not.

I have uninstalled - restarted - installed again but the issue is still the same.

Anymore ideas?

OS is Windows 8.1
Attachments
OfficeInstallVerification.png
OfficeInstalledVerification
OfficeInstallVerification.png (77.33 KiB) Viewed 727 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: ExcelConnector Issue

Post by Support Team » Tue Jun 09, 2015 2:51 pm

Hi VinRoxx,

This might be the same issue a customer faced after he uninstalled Office 2013 and installed 2007 again.
The issue was that the registry was corrupted and that he had to delete the registry entry of Office 2013 as you can see here: ExcelDataConnector stopped working.
Please try what is suggested in the provided link and let us know if this fixed your issue.

Regards,
Markus
.
Image

VinRoxx
Posts: 5
Joined: Sun Jun 07, 2015 6:31 pm

Re: ExcelConnector Issue

Post by VinRoxx » Tue Jun 09, 2015 5:43 pm

Hello Markus,

Thanks for the link and it did work for me as well. However I did few additional steps after deleteing the reg key mentioned in the link.

1) Delete the key which is above the excel PIA key and is related to Interlop because it didnt work by deleting just one key
2) Repair MS Offfice 2010, this would install the missing keys which were deleted from earlier version.
3) Restart

This time it worked like a charm :)

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: ExcelConnector Issue

Post by Support Team » Wed Jun 10, 2015 6:59 pm

Hi VinRoxx,

Thank you for your valuable feedback :).
I am glad it works now.

Regards,
Markus
.
Image