Exception

Ask general questions here.
strannik
Posts: 60
Joined: Tue Apr 29, 2014 3:00 pm

Exception

Post by strannik » Wed Jul 16, 2014 8:43 pm

Hi All,

I'm getting System.AccessViolationException sometimes when running scripts.

Anyone could tell me how to stop or fix it. Please see an attachment.

Thank you.
Attachments
exception.PNG
exception.PNG (38.83 KiB) Viewed 703 times

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Exception

Post by krstcs » Wed Jul 16, 2014 9:37 pm

Are you running Ranorex using the "Run As Administrator" option?
Shortcuts usually aren't...

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Exception

Post by Support Team » Thu Jul 17, 2014 7:25 am

Which Ranorex version do you use?
Do you experience this exception since an upgrade to a new Ranorex version?
Does the exception occur when automating a specific application or technology?
Do you use or reference any native assemblies (P/Invoke or C++/CLI) within your test projects?

Regards,
Alex
Ranorex Team
.
Image

strannik
Posts: 60
Joined: Tue Apr 29, 2014 3:00 pm

Re: Exception

Post by strannik » Wed Jul 23, 2014 8:47 pm

Version is 5.0.2.17874

I didn't upgrade and didn't use any application or technology as well any native assemblies.

Any idea.

Thanks.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Exception

Post by Support Team » Mon Jul 28, 2014 1:58 pm

Hi strannik,

I would highly recommend to uninstall Ranroex and the .NET Framework completely from your machine and install Ranorex again using the Ranorex 5.0.4.exe or the Ranorex 5.1.1.exe file.
If this will not help please send your solution to [email protected]. Does the exception occur on a specific section in your test?

Regards,
Bernhard
.
Image