exe file not run properly

Ask general questions here.
Ruser
Posts: 24
Joined: Wed Oct 07, 2009 3:26 pm

exe file not run properly

Post by Ruser » Fri Oct 15, 2010 11:02 pm

The testing runs without any problem in Ranorex Studio. I build the project into release and run the exe file on another server with runtime license only. The exe file can't run properly, the command windows showing for a while then disappear.

Anyone has the same probem? What might be the cause? Thanks.

grahamwbell
Posts: 1
Joined: Mon Oct 18, 2010 11:21 am

Re: exe file not run properly

Post by grahamwbell » Mon Oct 18, 2010 11:28 am

Hi, I had the same problem, the exe just doesn't run and gives no reason why.

I solved this by installing the same version on both machines. I had a newer version for the development than I had for the testing machine.

Maybe this is the same in your case?

Ranorex:
It would be nice if the runtime could say something about why it will not run...

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: exe file not run properly

Post by Support Team » Mon Oct 18, 2010 1:11 pm

Hi,

As grahamwbell said, please check if you have the same version of Ranorex on your runtime machine. The version of the runtime machine shouldn't be lower than the development machine.
As you know Ranorex executable is normally a console application and you have the possibility to run each console application via the command line of windows. If you start the application by the command line of windows, I'm pretty sure you get an error message with more details. The error message should be also available in the generated report of the executable.

Regards,
Peter
Ranorex Team
.
Image

Ruser
Posts: 24
Joined: Wed Oct 07, 2009 3:26 pm

Re: exe file not run properly

Post by Ruser » Mon Oct 18, 2010 4:09 pm

Thank you both. Run time version was the problem. It is working now.