Extension for Firefox is installed + enabled but not working

Ranorex Spy, Recorder, and Studio.
mgpmul
Posts: 4
Joined: Wed Jan 03, 2018 5:57 pm

Extension for Firefox is installed + enabled but not working

Post by mgpmul » Wed Jan 10, 2018 6:02 pm

I have Ranorex installed and re-installed the Firefox extension for Firefox several times, but it still is not working.
I've used the instrumentation wizard of Ranorex to do so.

Ranorex extension is installed and enabled, as can be seen in the screenshot nr. 1.
FirefoxRanorexExtensionEnabled.png
FirefoxRanorexExtensionEnabled.png (18.97 KiB) Viewed 456 times

As soon as I re-open Firefox, a pop-up is shown stating that the Ranorex plugin has stopped working (Ranorex.Plugin.FirefoxMsgHost ).
This occurs both when I open Firefox manually or as the first step in a recording. See screenshot nr 2.
FirefoxRanorexPluginStoppedWorking.png
FirefoxRanorexPluginStoppedWorking.png (8.94 KiB) Viewed 456 times
When selecting the Debug option, using VisualStudio as a debugger, an InvalidOperationException is displayed.
The full error message is:
"System.InvalidOperationException was unhandled
Message: An unhandled exception of type 'System.InvalidOperationException' occurred in System.dll
Additional information: Cannot load Counter Name data because an invalid index '' was read from the registry."

What is the cause and how to fix?

* Ranorex version
Ranorex version: 7.2.1
Browser: Firefox, version 57.0.3 32-bit (this is the latest version)
Ranorex add-on for Firefox is enabled: version 1.0.39
* OS version
Windows 10

asdf
Posts: 174
Joined: Mon Mar 21, 2016 3:16 pm

Re: Extension for Firefox is installed + enabled but not working

Post by asdf » Mon Jan 15, 2018 10:50 am

It seems that you didn't get the right version of the FF plugin.
Have you tried to right-click on the add-on and press "Find Updates"?