ExtJS Selector problem

Ranorex Spy, Recorder, and Studio.
andrefelipe
Posts: 13
Joined: Tue Feb 03, 2015 6:00 pm

ExtJS Selector problem

Post by andrefelipe » Fri Feb 06, 2015 2:15 pm

Hello,

1. What version of Ranorex are you using?
5.2.2

2. What Windows version are you using?
Win 7 Enterprise SP1

We have a TreeviewMenu in our app. And it's using so many <ul> and <li> and sometimes they are in a random order, so I can't map it by it's <li> index. But theres one property that "never" changes, it's the:

Code: Select all

ext:tree-node-id
So I was trying to interact with my menu using this. But I've found two problems.

The code below, works on spy, and highlights the correct element, it's pretty good, but I can't save it because it looks like a "wrong" sintax near to "@ext:" so I've tried to store it in a variable, and use it to map, but it didn't work.

Code: Select all

/dom[@domain='192.168.3.9']//div[#'object__modules']//ul/div/li/div[@ext:tree-node-id='module_73']
The seccond problem is that this selector works perectly (on spy only, ofc because I can't save it to use) on Chrome and Firefox, but doesn't work on IE.

Thanks in advance.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: ExtJS Selector problem

Post by Support Team » Mon Feb 09, 2015 10:35 am

Hello andrefelipe,

May I ask you to post or send (to [email protected]) three Ranorex snapshot files of the specific div element you have troubles with? Please send or post one from each browser, so one from Chrome, one from Firefox and one from IE.
These snapshots will help me in analyzing your issue.
The following link will show you how to generate a snapshot file: Creating Ranorex Snapshot Files.

Thanks,
Markus
.
Image

andrefelipe
Posts: 13
Joined: Tue Feb 03, 2015 6:00 pm

Re: ExtJS Selector problem

Post by andrefelipe » Mon Feb 09, 2015 5:34 pm

I'll do it as soon as possible. Thank you very much!