Facing problem WPF application with attribute 'Text'.

Ask general questions here.
abhay4
Posts: 1
Joined: Fri Sep 04, 2015 12:12 pm

Facing problem WPF application with attribute 'Text'.

Post by abhay4 » Fri Sep 04, 2015 1:12 pm

Hi,

While performing UI Automation test on WPF .net application with Ranorex , I am facing following problem.Please help!

1. It gives a warning message.
Failed to instrument Qt process. Please make sure you have enough privileges to access the process and a supported version of Qt.
(This message is only shown once per report.)
2. After that it gives following errors.
i)Attribute 'Text' of element for item 'EBSrelatdRepository.EliteBonusingSuite140001.EliteBonusingSuite14000' does not match the specified value (Failed to find item 'EBSrelatdRepository.EliteBonusingSuite140001.EliteBonusingSuite14000'. No element found for path '/form[@wpfnative='True' and @title~'^Elite\ Bonusing\ Suite\ 14\.0' and @processname='BallyTech.BonusingServer.Apps.Shell']/container/container/container[1]/container/text[@caption~'^Elite\ Bonusing\ Suite\ 14\.0']' within 1m.).
ii)Module execution was aborted because a validation step has failed. Attribute 'Text' of element for item 'EBSrelatdRepository.EliteBonusingSuite140001.EliteBonusingSuite14000' does not match the specified value (Failed to find item 'EBSrelatdRepository.EliteBonusingSuite140001.EliteBonusingSuite14000'. No element found for path '/form[@wpfnative='True' and @title~'^Elite\ Bonusing\ Suite\ 14\.0' and @processname='BallyTech.BonusingServer.Apps.Shell']/container/container/container[1]/container/text[@caption~'^Elite\ Bonusing\ Suite\ 14\.0']' within 1m.).
Show/Hide Stacktrace

Because of these two problems i am unable to proceed.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Facing problem WPF application with attribute 'Text'.

Post by odklizec » Mon Sep 07, 2015 12:55 pm

Hi,

Unfortunately, there is a lot of missing info in your post. Please answer the following questions...

Your Ranorex version?
Have you recently upgraded Ranorex with latest version?
Is your application QT based, if so, which QT version is used?
Are you sure the QT has enabled accessibility? Check this support >page<.

If your application is not QT based, please make sure there is no other QT app running in the background, e.g. Oracle VirtualBox. This could cause false instrumentation warnings, not related to your app. Eventually, you can put an app to "ignore list" so Ranorex will stop throwing instrumentation error (check this post).

As for the other error, could you please post Ranorex Snapshot (not screenshot!) of the element in question?
What happens if you track the element with Spy? Does the Spy path match the one used in your test?

This particular piece of path is in my opinion very fragile and most likely to fail with each new version of the application under test...

Code: Select all

/form[@wpfnative='True' and @title~'^Elite\ Bonusing\ Suite\ 14\.0' 
You should remove the version number from the path ;)
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration