Fail to Generate Log File

Bug reports.
gary
Posts: 17
Joined: Thu Sep 22, 2016 2:52 pm

Fail to Generate Log File

Post by gary » Fri Mar 03, 2017 10:51 am

Hi Guys

I would like to report an issue I experienced with Ranorex.
Every time I execute my test it does not generate the log file of the result. Earlier it use to generate log files everytime the run was success or fail. I am using version 6.2.1. I was wondering if I have changed some setting accidentally as it was working all fine couple of days back? Any help in this regard is much appreciated.

Thank you.

McTurtle
Posts: 191
Joined: Thu Feb 23, 2017 10:37 am
Location: Benedikt, Slovenia

Re: Fail to Generate Log File

Post by McTurtle » Fri Mar 03, 2017 11:31 am

Hello Gary,

There is an option to turn off opening reports right after the test suite completes. The report is still generated and is located in the ../bin/Debug folder.

To access this option go to "Tools"->"Option" and find the "Open report after execution"option and make sure it is not disabled.
Open_report_after_Excution.png
Open_report_after_Excution.png (17.38 KiB) Viewed 849 times
Additionally it is possible that generating a report is totally disabled in your test case options. If this has been done you can check following the below steps.

1. Go to "View Test Suite", right click on your Test Suite and select properties
Properties_TestSuite.png
Properties_TestSuite.png (11.49 KiB) Viewed 849 times
Find the "Enable report" checkbox under Test Suite properties
Enable_report.png
Enable_report.png (4.89 KiB) Viewed 849 times
Please check these and let us know if they were both checked.

Regards,
McTurtle

gary
Posts: 17
Joined: Thu Sep 22, 2016 2:52 pm

Re: Fail to Generate Log File

Post by gary » Mon Mar 06, 2017 5:13 pm

McTurtle wrote:Hello Gary,

There is an option to turn off opening reports right after the test suite completes. The report is still generated and is located in the ../bin/Debug folder.

To access this option go to "Tools"->"Option" and find the "Open report after execution"option and make sure it is not disabled.
Open_report_after_Excution.png
Additionally it is possible that generating a report is totally disabled in your test case options. If this has been done you can check following the below steps.

1. Go to "View Test Suite", right click on your Test Suite and select properties
Properties_TestSuite.png
Find the "Enable report" checkbox under Test Suite properties
Enable_report.png
Please check these and let us know if they were both checked.

Regards,
McTurtle
Hi McTurtle

All the suggest options are enabled but still it fails to generate the log report....not sure if there is anything else we can do. Thanks

McTurtle
Posts: 191
Joined: Thu Feb 23, 2017 10:37 am
Location: Benedikt, Slovenia

Re: Fail to Generate Log File

Post by McTurtle » Tue Mar 07, 2017 4:10 pm

Hello Gary,

I have a 2nd suggestion. Try to delete the file C:\Users\<YOUR_USER_NAME>\AppData\Roaming\RanorexRecentReports.dat as it could be corrupted.

Pleas let me know if this helped.

Regards,
McTurtle

starstuff
Posts: 5
Joined: Thu Mar 30, 2017 10:36 pm

Re: Fail to Generate Log File

Post by starstuff » Thu Mar 30, 2017 10:46 pm

I had the exact same problem as the original poster. The solution to delete the dat file worked to fix this issue.

syartsev
Posts: 7
Joined: Thu Aug 10, 2017 4:54 pm

Re: Fail to Generate Log File

Post by syartsev » Wed Oct 18, 2017 5:07 pm

Deleting .dat file worked for me