Fail to launch app if not running in background on iOS

Bug reports.
tvu
Posts: 195
Joined: Tue Apr 07, 2015 10:47 pm

Fail to launch app if not running in background on iOS

Post by tvu » Mon Oct 24, 2016 6:13 pm

Summary:
Launching a second instrument mobile app while another one is running in the foreground will fail if that second app is not already running in the background.

Setup:
  • Ranorex 6.1.0
  • WIndows 8.1 Enterprise
  • iOS devices running iOS 10.0.2
Prerequisite:
Two instrumented iOS Apps.

Reproduction Steps:
  • On device, manually close down all apps
  • Manually launch the Ranorex Service App
  • From Studio or Spy, launch the first app
  • The first app should launch twice and be recognized as running by Spy
  • While the first app is running, use Studio or Spy to launch your second app
Result:
The second app will launch once and then go to the iOS Home screen.

Note:
App #1 was our mobile app. App #2 was the RxBrowser. The bug also occurs when switched.

I was able to reproduce this on multiple devices which all was running iOS 10.0.2. In general, we try to launch the RxBrowser while our mobile app is running. I was also able to reproduce this from a recording.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Fail to launch app if not running in background on iOS

Post by Support Team » Tue Oct 25, 2016 2:20 pm

Hello tvu,

I was not able to duplicate your issue (Ranorex 6.1.1, Windows 10, iOS 10.0.2). May I ask you to contact [email protected]? We will need further information in order to analyze your issue.

Thank you in advance.

Regards,
Ned
.
Image