Failed to detect tooltip and image validation

Ask general questions here.
Grace
Posts: 5
Joined: Thu Sep 05, 2013 4:55 am

Failed to detect tooltip and image validation

Post by Grace » Thu Sep 05, 2013 5:28 am

Hi,

It seems like ranorex can't detect tooltip of my application,
I've been try using the spy and recorder hotkeys..but none of them works
The tooltip will appear when I move the cursor to the icon, and will be disappear when I move the cursor away

Image

and as you see in the image above..there are two field with red cross icon in it
that red cross will disappear once I fill one of the field,but instead of detect the red cross for
each field, ranorex detect the red cross for a whole application. So I can't make a validation for it.
Is there any way out for these problems ?.

Thank you.

Grace

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Failed to detect tooltip and image validation

Post by Support Team » Fri Sep 06, 2013 2:39 pm

Hello Grace,

There are already some threads in the forum treating similar issues. Mybe one of them can help you solving your issue. Regards,
Bernhard
.
Image

Grace
Posts: 5
Joined: Thu Sep 05, 2013 4:55 am

Re: Failed to detect tooltip and image validation

Post by Grace » Mon Sep 09, 2013 3:43 am

Hi Bernhard,

Thank you for your suggestions. I've been trying it, but still none is tracked as you can see in the screenshot below.

Image

Is there any other way to capture the tooltip ?.

Thanks :D


Regards,

Grace

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Failed to detect tooltip and image validation

Post by Support Team » Mon Sep 09, 2013 5:29 pm

Hello Grace,

It is hard to analyze the issue without having your application.
Would it be possible to get your application or a sample in order to analyze the issue?
Thank you!

Regards,
Bernahrd
.
Image

Grace
Posts: 5
Joined: Thu Sep 05, 2013 4:55 am

Re: Failed to detect tooltip and image validation

Post by Grace » Wed Sep 11, 2013 4:23 am

Hi Bernahrd,

I'm sorry currently I can't give you example of the app.
And I'm so sorry before,because this application is using DevExpress and its function is IDXDataErrorInfo
So, I guess It's possible that the red cross and the tooltip is not an object but an image.

Is there any possible way to validate these ?,except image validation, because we're
using three different computers with different image resolutions.

Thanks a lot


Regards,

Grace

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Failed to detect tooltip and image validation

Post by Support Team » Wed Sep 11, 2013 3:13 pm

Hello Grace,

It is hard to say if there is another possibility in order to validate the tooltip without having a snapshot.
Is it not allowed to send a snapshot or is it not possible to create a snapshot file?

If it is not possible to create a snapshot file, you can try to use the SCROLL key to do this.
Please try to follow the steps below:
  • Track your application / the element with the tool tip using Ranorex Spy
  • Wait until the tooltip apears and press the SCROLL key on your keyboard
  • Wait until Ranorex Spy is ready creating the snapshot file.
Please also read the section "Creating Ranorex Snapshot Files" in order to get a more detailed description.
Thank you!

Regards,
Bernhard
.
Image

Grace
Posts: 5
Joined: Thu Sep 05, 2013 4:55 am

Re: Failed to detect tooltip and image validation

Post by Grace » Wed Sep 18, 2013 3:10 am

I'm sorry for the late reply, but here's the snapshot of the apps.Thanks!


Best Regards,


Grace
Attachments
Tooltip.rxsnp
(227.73 KiB) Downloaded 158 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Failed to detect tooltip and image validation

Post by Support Team » Thu Sep 19, 2013 12:35 pm

Hello Grace,

Thank you for the snapshot file.
Unfortunately I cannot find the tooltip.
Would it be possible to have a remote session in order to analyze the issue in more detail?

Regards,
Bernhard
.
Image

Grace
Posts: 5
Joined: Thu Sep 05, 2013 4:55 am

Re: Failed to detect tooltip and image validation

Post by Grace » Fri Sep 27, 2013 3:59 am

Hello Bernhard,

I'm sorry for the late reply. Sure, just PM me for the time.
Thanks.

Best Regards,


Grace