"Failed to extract report file" Error

Bug reports.
Ajitpatil3011
Posts: 37
Joined: Thu Aug 22, 2019 4:14 pm

"Failed to extract report file" Error

Post by Ajitpatil3011 » Thu Sep 05, 2019 2:45 pm

I run the script for 12 hours from Ranorex tool which is Installed on my VM and the execution was happening via Ranorex Agent on Real machines which is connected to hardware. After execution when I try to Open the failure report I am getting this error.

I have attached screenshot of the Error and
Report Error.png
Report Error.png (33.09 KiB) Viewed 572 times
Ranorex Tool screen when I try to open the report.
Ranorex Tool screen.png
Ranorex Tool screen.png (24.32 KiB) Viewed 572 times

Ranorex Version : 9.0.1
Ranorex Agent Version : RanorexRemoteAgent-5.0.0

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6544
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: "Failed to extract report file" Error

Post by odklizec » Thu Sep 05, 2019 3:14 pm

Hi,

My guess is that the report file is simply too large to open. There is most probably nothing that you can do with existing report file. And the only workaround for future is to run your tests in smaller chunks. Your 12h test simply produces too large report.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Ajitpatil3011
Posts: 37
Joined: Thu Aug 22, 2019 4:14 pm

Re: "Failed to extract report file" Error

Post by Ajitpatil3011 » Thu Sep 05, 2019 3:49 pm

Thank you for clarification odklizec.

YvesL
Posts: 12
Joined: Mon Jan 13, 2020 2:20 pm

Re: "Failed to extract report file" Error

Post by YvesL » Mon Nov 09, 2020 11:12 am

This is strange because apparently your compressed report has a size of 2.304KB.
That's not that large, even without a video report in it.
I've had much bigger reports, they just take more time to open.

I came across this tread because I'm having a SIMILAR ISSUE today.

When I try to open my COMPRESSED report, I get this error message "Failed to extract report file. [...] Cannot find central directory".

Does anyone know what it means ?

2020-11-09 11_00_25-vw01084 - Connexion Bureau à distance.jpg
2020-11-09 11_00_25-vw01084 - Connexion Bureau à distance.jpg (134.46 KiB) Viewed 215 times

YvesL
Posts: 12
Joined: Mon Jan 13, 2020 2:20 pm

Re: "Failed to extract report file" Error

Post by YvesL » Mon Nov 09, 2020 11:20 am

It looks like the compressed report (.rxzlog") is corrupted: it only contains the .rxlog file ... the rest is missing.

This is the 1st time is encounter this error .. all my other compressed reports were ok so far.