Failed to find item

Mobile Testing, Android App Testing.
superyl
Posts: 3
Joined: Wed Oct 23, 2013 10:04 am

Failed to find item

Post by superyl » Wed Jul 30, 2014 5:03 am

Hi
I played the script,but it always failed to find item:
Failed to find item 'dlRepository.ComInspurThinkmobile135.DhpBtnDlvArri'.
No element found for path '/mobileapp[@title='com.inspur.thinkmobile135']/form[@title='HomePageActivity']//container[@rid='tabcontent']/form[2]/?/?/container[@rid='content']//container[@rid='dhp_rl_dlvInfo']/container[@rid='dhp_rl_dlvBtnInfo']/button[@rid='dhp_btn_dlvArri']' within 1m.
And the log shows "Screenshot is not available",but the screen on mobile is available.
The path is not changed.
I am looking forward to hear from you.
Thanks a lot.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Failed to find item

Post by Support Team » Thu Jul 31, 2014 3:26 pm

Hi superyl,

Unfortunately it is hard to analyze this issue.

May I therefore ask you to answer the following questions?
  • Which version of Ranorex are you using?
  • Is it possible for you to attach a snapshot?
    • Please have a look in our User Guide, to see how to create a Ranorex Snapshot.
  • Additionally: is it possible to get your application?
This will help us to analyze the issue on our side.

P.S.: If you don’t want to post the snapshot here in the public forum, you can send it to [email protected]
Thank you in advance.

Regards,
Markus (S)
.
Image