Fails Image Verification But they are the same ?

Ask general questions here.
sonardyne
Posts: 4
Joined: Mon Jul 06, 2015 9:43 am

Fails Image Verification But they are the same ?

Post by sonardyne » Wed Jul 29, 2015 4:32 pm

Hi currently I have an annoying issue I am trying to validate that 3 buttons are illuminated meaning they are enabled and when I run the test it fails but has the same image in expected and searched so surley it sees the correct image.

I also have issue sometimes when it is greyed out meaning it is deactivated the test passes thinking it has the correct image even though the image has no colour in it .
Attachments
Image Verification error.PNG
Image Verification error.PNG (98.59 KiB) Viewed 610 times

sonardyne
Posts: 4
Joined: Mon Jul 06, 2015 9:43 am

Re: Fails Image Verification But they are the same ?

Post by sonardyne » Wed Jul 29, 2015 4:38 pm

I reduced the Image similarity and now it works is this the correct setting to change?

Thanks

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Fails Image Verification But they are the same ?

Post by Support Team » Thu Jul 30, 2015 10:32 am

Hello sonardyne,

Yes, sometimes it is necessary to slightly decrease the similarity. Since Ranorex 5.4 it is possible to report the actual similarity and difference of the compared pictures. Maybe this could also help you in adjusting the similarity.

CompareImage -> Properties tab
CompareImageReportSimilarity.png
CompareImageReportSimilarity.png (9.16 KiB) Viewed 589 times
Regards,
Robert
.
Image