File Upload Not working in Remote Execution

Ask general questions here.
sarchana
Posts: 1
Joined: Wed Jun 24, 2020 1:16 pm

File Upload Not working in Remote Execution

Post by sarchana » Fri Oct 02, 2020 11:18 am

I have a testcase to upload an File when I perform this testing from my system it works fine.
But when the same test case is executed in remote it fails.
I have added the file to be uploaded inside the project as mentioned in the below link
add-file-as-resource-t13413.html

In the Remote execution the file upload link opens the Windows Explorer but the input value ./fileneme is not being entered, it fails with the below message
Please check that your whitelist allows Ranorex to access the process.
No element found for path


I have also added windows explorer to the whitelist. Am I missing some steps?

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6263
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: File Upload Not working in Remote Execution

Post by odklizec » Mon Oct 05, 2020 6:02 pm

Hi,

Have you tried to connect to remote machine. via Remote Desktop and eventually, debug the problem directly on that machine? Of course, you will have to install Ranorex on that machine. It’s the best and easiest way to figure what’s wrong 😉
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration