'files/' contains the disallowed character '/'

Ranorex Spy, Recorder, and Studio.
tvu
Posts: 195
Joined: Tue Apr 07, 2015 10:47 pm

'files/' contains the disallowed character '/'

Post by tvu » Mon Oct 03, 2016 9:51 pm

I am getting an error that says a filename is using the character '/'. This occurs when I try to trigger a job via Remote Agent. My local computer can publish the job, but on the remote computer the job won't even run because of this error. I don't get the error when I compile and run the job locally.

I can't figure out where this is coming from. Has anyone experience this?
Attachments
filename_error.png
Filename Error
filename_error.png (24.84 KiB) Viewed 632 times

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: 'files/' contains the disallowed character '/'

Post by krstcs » Tue Oct 04, 2016 1:23 pm

The '/' (forward-slash) character is not allowed in file names in Windows. You are using one somewhere in your test.

Use '\' (backslash) if you want to separate directory and file names in a path.
Shortcuts usually aren't...

tvu
Posts: 195
Joined: Tue Apr 07, 2015 10:47 pm

Re: 'files/' contains the disallowed character '/'

Post by tvu » Tue Oct 04, 2016 6:10 pm

Thanks krstcs,

I figured as much, but for the life of me I can't figure out where. I revert my projects back a couple of weeks where I wasn't experience the issue, but it still happens. It's only an issue when I use the Remote Agent.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3921
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: 'files/' contains the disallowed character '/'

Post by odklizec » Tue Oct 04, 2016 6:35 pm

Hi,

Have you tried to search the entire solution for the appearance of "files/" string?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

tvu
Posts: 195
Joined: Tue Apr 07, 2015 10:47 pm

Re: 'files/' contains the disallowed character '/'

Post by tvu » Tue Oct 04, 2016 6:42 pm

Thanks odklizec,

I've already done that and the search results didn't come back with anything.

Vaughan.Douglas
Posts: 250
Joined: Tue Mar 24, 2015 5:05 pm
Location: Des Moines, Iowa, USA

Re: 'files/' contains the disallowed character '/'

Post by Vaughan.Douglas » Mon Oct 31, 2016 3:06 pm

it's in your "filename" parameter.
Doug Vaughan