Finding color of a cell in DevExpress grid

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
weinnir
Posts: 15
Joined: Tue Feb 09, 2010 9:42 pm

Finding color of a cell in DevExpress grid

Post by weinnir » Thu May 27, 2010 12:21 am

Hello,
I know that Ranorex supports DevExpress suite, my question is very similar to this one: http://www.ranorex.com/forum/finding-th ... t1030.html
though as opposed to Infragistics, DevExpress should be recognizable.
Also, I can't modify the code in the application to include the remote invoke so i'm hoping there's a different approach I can use.
I'm trying to get the colour of a cell (actually just the foreground) and I can't use image comparison as the text in the cell keeps changing all the time.
I can't find any appearance attribute to the cell, which is in fact not recognized as a DevExrpess cell but just as a cell (this is a regular DevExpress grid, not PivotGrid)
Enclosed is the properties window of the cell (the attributes don't have any appearance in them either).
I'm using Ranorex 2.2.2.7850 on win xp pro SP3. DevExpress 9.3.4 (if it matters).
Thanks!
cell.png
cell.png (34.36 KiB) Viewed 2698 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Finding color of a cell in DevExpress grid

Post by Support Team » Thu May 27, 2010 12:59 pm

Hi,

Sorry but there is no way out of the box to get the fore color of the cell. We don't get this property of the cell. The only way is to write its own method, which read the pixel of a picture from the cell and return the expected color. Another solution would be, that you ask your developer if it's possible to write the fore color to an accessibility property for example @accessibledescription. So Ranorex is able to get the string of the fore color.

Regards,
Peter
Ranorex Support Team
.
Image

weinnir
Posts: 15
Joined: Tue Feb 09, 2010 9:42 pm

Re: Finding color of a cell in DevExpress grid

Post by weinnir » Thu May 27, 2010 4:06 pm

Thanks for the quick reply.
I'll see what I can do about the pixel colour