FireFox 24.0 ESR and Ranorex 4.1 plug-in disabled

Ask general questions here.
User avatar
Aracknid
Posts: 342
Joined: Tue Aug 10, 2010 3:23 pm
Location: Toronto, Ontario, Canada

FireFox 24.0 ESR and Ranorex 4.1 plug-in disabled

Post by Aracknid » Thu Sep 26, 2013 6:21 pm

Hi,

I just installed FireFox 24.0 ESR and I also installed (upgraded to) Ranorex 4.1. In FF, the Add-ons Manager says that Ranorex Automation is incompatible with Firefox 24.0 and the plug-in is disabled.

Did I do something wrong? Should I uninstall and re-install the plug-in (please point me on how to do this) or is there a bug?

Thanks,

Aracknid.

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: FireFox 24.0 ESR and Ranorex 4.1 plug-in disabled

Post by krstcs » Thu Sep 26, 2013 6:40 pm

See the release notes: http://www.ranorex.com/download/release ... html#c5904

Ranorex 4.1.0 (released Aug. 7) DOES NOT support FF 24. FF 24 was release to BETA the day before 4.1.0 was released.

Ranorex 4.0.6 (released Sep. 4) DOES support FF 24.

If you want to use FF 24 you will have to use 4.0.6 until they release a version of 4.1(.1?) that does support it.
Shortcuts usually aren't...

User avatar
Aracknid
Posts: 342
Joined: Tue Aug 10, 2010 3:23 pm
Location: Toronto, Ontario, Canada

Re: FireFox 24.0 ESR and Ranorex 4.1 plug-in disabled

Post by Aracknid » Thu Sep 26, 2013 6:47 pm

I didn't realize that 4.0.x stream and 4.1.x streams are different. I didn't notice the release dates where not in chronological order. I just assumed 4.1 was newer than 4.0.6 and that all fixes in 4.0.6 where in 4.1

Suggest that you make this more clear. Don't display the releases in order like that on the web site. Make them in order by stream. Also, I suggested this a long time ago too... make the currency of browsers (which is likely the most important thing to most testers) clear for each stream.

I hate wasting time setting up environments only to find out I have the wrong stuff.

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: FireFox 24.0 ESR and Ranorex 4.1 plug-in disabled

Post by krstcs » Thu Sep 26, 2013 9:00 pm

Note: I'm not from Ranorex. I'm just pointing out what their release notes say.

The releases are ordered by version number, not by date. They have done it this way since the beginning. As with any other software, it is up to the user to make sure they are getting the version they need when they download it.


I have said before, expecting them to release software (even browser plugins) on the same schedule as the 3rd-party vendors they are supporting is like expecting home builders to start building houses without the blueprints. What version do they build their plugin against? Alpha? Nightly? Things in those states WILL change, so Ranorex will be throwing manpower against something they know will change. How does that make sense? I would guess that they already do a lot of the pre-development work based on the ALPHA of each browser (when they can get it).

In this instance, they put the functionality into 4.0.6 as a maintenance release for 4.0, based on the FF BETA. I would guess they will do the same with 4.1.1 and will include FF 25, but they have other things that need to be included in that release (bug fixes, etc.) and it doesn't make sense for them to release a small update that just covers 1 of the many technologies they support. As testers, we, above all, should understand the amount of regression they have to do for any release, and how little sense it makes to waste that time on such a small piece.

Given their current release schedule, I would expect 4.1.1 withing a few weeks.
Shortcuts usually aren't...