Firefox with ATag and InputTag PerformClick not working

Bug reports.
JamesY
Posts: 4
Joined: Thu Apr 22, 2010 9:03 pm

Firefox with ATag and InputTag PerformClick not working

Post by JamesY » Thu Apr 22, 2010 9:23 pm

Hi,

I have been evaluating the Ranorex software and I like it, but I have noticed a strange issue. I don't know if it is a bug or just a technical limitation but I have found that when trying to automate Firefox using the Firefox plugin, that both the ATag and InputTag (when the input is a submit button) adapters PerformClick method don't do anything unless I first call .Focus() on the adapter.

This works but causes the page to jump around a lot which I would prefer it not to. Is this a known issue? And is there a fix on the way?

I am using Firefox 3.6.3.8345 and Ranorex 2.2.2.7580 and now also 2.3 on a Windows XP Pro SP3 pc if any of that helps.

Thanks

James

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Firefox with ATag and InputTag PerformClick not working

Post by Support Team » Fri Apr 23, 2010 12:46 pm

Hi!

No it's no bug in Ranorex it's a technical limitation in Firefox. PerformClick with Internet Explorer will work and the page will not jump around. In Firefox there is currently no other way, because the DOM implemenation of this browser is different to IExplorer. But use EnsureVisbile() instead of Focus(), because EnsureVisible() only set the item to visible and don't set the focus to the item.
In a future release a solution will be implemented, that these browsers have the same behavior.

Regards,
Peter
Ranroex Support Team
.
Image

JamesY
Posts: 4
Joined: Thu Apr 22, 2010 9:03 pm

Re: Firefox with ATag and InputTag PerformClick not working

Post by JamesY » Fri Apr 23, 2010 2:19 pm

Thank you for your quick reply.

I tried using EnsureVisible and you are correct that it works, we will use that from now on.

Thanks

James.