GDI issues in Windows 10 (pre Anniversary update)

Bug reports.
BSullivan
Posts: 29
Joined: Thu Jun 04, 2015 6:31 pm
Location: HorseHeads NY
Contact:

GDI issues in Windows 10 (pre Anniversary update)

Post by BSullivan » Fri Dec 02, 2016 4:40 pm

After moving to 6.2 I noticed that Ranorex was interacting with my AUT in a strange way. It sounds like the "known issue" described in the release notes, but I am currently not using the Windows 10 anniversary edition.

An example...

The control that I want to interact with is pictured here:
context.png
context.png (11.47 KiB) Viewed 652 times
When Ranorex tries to interact with it (only using 6.2), it looks like this:
blank_Context.png
blank_Context.png (6.54 KiB) Viewed 652 times
Now this looks to only be a visual issue, because Ranorex is still able to find the text, validate it, and in all other ways interact with it although it is not visible. The issue is that the screenshots that are captured when a test fails are now no longer helpful.

Is anyone else seeing something like this, or should the release notes refer to Windows 10 in general rather than the Anniversary update?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: GDI issues in Windows 10 (pre Anniversary update)

Post by Support Team » Mon Dec 05, 2016 12:44 pm

Hi BSullivan,

In order to figure out if this issue is related to the known issue mentioned in the release notes, please contact [email protected] by email. Furthermore, please attach a Ranorex Snapshot of the AUT and the complete Windows 10 version.

We look forward to hearing from you.

Sincerely,
Johannes
.
Image

BSullivan
Posts: 29
Joined: Thu Jun 04, 2015 6:31 pm
Location: HorseHeads NY
Contact:

Re: GDI issues in Windows 10 (pre Anniversary update)

Post by BSullivan » Mon Dec 05, 2016 5:13 pm

I have emailed support with that information.