Global Parameters name with space

Ranorex Spy, Recorder, and Studio.
Jeremie
Posts: 9
Joined: Thu Jul 21, 2011 9:18 am

Global Parameters name with space

Post by Jeremie » Fri Aug 19, 2011 8:35 am

Hi

I launch my test suite with a batch and I include global parameters /pa like this
MyExeFile /pa:MyGlobalParametersName=MyVar

But when MyVar contain string with space only the first word is my globalparameters Name

Exemple :
MyVar = To To
The global Parameter Name is To

It is possible to have Global Paramaters name with space ? If yes, how i can delimitate the name ?

Thanks

User avatar
Support Team
Site Admin
Site Admin
Posts: 11710
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Global Parameters name with space

Post by Support Team » Fri Aug 19, 2011 9:51 am

Hi,

If you want to use spaces in the command line you have to use quotation marks.

Example:
"MyVar=To To"

Regards,
Markus
Ranorex Support Team
.
Image

Jeremie
Posts: 9
Joined: Thu Jul 21, 2011 9:18 am

Re: Global Parameters name with space

Post by Jeremie » Fri Aug 19, 2011 10:26 am

I have try, but doesn't work

if In batch MyVar="To To"
In ranorex my global parameter Name is "To

User avatar
Support Team
Site Admin
Site Admin
Posts: 11710
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Global Parameters name with space

Post by Support Team » Fri Aug 19, 2011 11:16 am

Please, enclose the whole parameter assignment in quotation marks, e.g.:

Code: Select all

MyExeFile /pa:"MyGlobalParametersName=To To"
Regards,
Alex
Ranorex Team
.
Image

Jeremie
Posts: 9
Joined: Thu Jul 21, 2011 9:18 am

Re: Global Parameters name with space

Post by Jeremie » Fri Aug 19, 2011 11:25 am

Oh sorry
I have not looking correctly your answer

It's OK now

Thanks a lot