How to get the Debug mode to respect breakpoints?

Ranorex Spy, Recorder, and Studio.
Buphagus
Posts: 6
Joined: Sat Jul 02, 2016 3:04 am

How to get the Debug mode to respect breakpoints?

Post by Buphagus » Tue Sep 04, 2018 11:53 pm

I have breakpoints set in the code. Debug mode is enabled. I start a run (with debugger).
The test run starts and completes and the breakpoints are not tripped.
(one breakpoint is on a report.log statement, that was modified for this test. The new message appears in the log, but it did not stop at this point).

How do I get the breakpoints to be respected?

I am trying to test a WPF application, though this is failing long before touching the app; in usercode of execController.
I am modifying /extending an inherited working test suite.

This is a Windows 10 OS. with Ranorex 8.2.1

Thank you,
Bill

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3925
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: How to get the Debug mode to respect breakpoints?

Post by odklizec » Wed Sep 05, 2018 7:39 am

Hi,

It sounds like a problem with project/Ranorex studio configuration? Have you tried to create a new solution with breakpoints? If they works in new solution, try to simulate the situation from your old solution.

At first, copy all settings (both Ranorex studio settings and project settings), from old solution to new one. If the breakpoints still work in new solution, try to add the user code from the non-working project.

BTW, have you tried to debug the solution on another machine? Try also uninstall and re-install Ranorex.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration