IE - Browser start and close won't work with Setup & Teardown

Ask general questions here.
meric
Posts: 4
Joined: Sat Jun 29, 2019 12:31 pm

IE - Browser start and close won't work with Setup & Teardown

Post by meric » Sat Jun 29, 2019 12:41 pm

Hi,

I am using Ranorex 9.1.0 with any browser. Any help would be greatly appreciated. Thanks!

Browser close won't work even with close application, CloseWindowByProcessID with Application Under Test. It's not even working with simple browser open and close. It throws this error.

"00:05:257 Error Modules: Input string was not in a correct format....


at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal) at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info) at System.Int32.Parse(String s) at MyTest6.CloseBrowser.Ranorex.Core.Testing.ITestModule.Run() in c:\Users\meric\Documents\Ranorex\RanorexStudio Projects\MyTest6\MyTest6\CloseBrowser.cs:line 96 at Ranorex.Core.Testing.TestModuleLeaf.RunInternal(DataContext parentDataContext, Int32 iteration, Int32 iterationCount, Boolean skipIteration)"

User avatar
qwertzu
Posts: 265
Joined: Wed Jan 25, 2017 11:08 am

Re: IE - Browser start and close won't work with Setup & Teardown

Post by qwertzu » Mon Jul 01, 2019 11:50 am

hi,

I'm afraid without more details, the community won't be able to help.
can you show us how exactly you implemented the step for closing the browser?
Please post your the code or a screenshot of the ranorex action.

regards, qwertzu