IE11 locking/crashing when repo object not found

Bug reports.
krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

IE11 locking/crashing when repo object not found

Post by krstcs » Fri Jan 03, 2014 3:44 pm

Windows 7 x64 w/IE 11
Ranorex 4.1.4

When I try to search for an object in IE 11 (haven't tried with 10/9/8) and the object is not found immediately, Ranorex (or the test if I'm running one) and the IE plugin lock up and cause IE to stop responding. IE then tries to recover the page, but this does not always work. It seems like the search timeout is not always being respected (but this could just be the perception due to the contention over resources or something similar).

I don't have the issue unless I'm running Ranorex, or a test, and the item is not found. This seems to have started with 4.1.4 as I don't see this behavior in 4.1.3 (but I wasn't on 4.1.3 very long for what it's worth).


As a secondary side issue, I'm also having problems with object identification and timeouts with 4.1.4 (although some of these seem to have started with 4.1.0) that are intermittent and not reproduceable on my part which makes them very hard to figure out. In general, all of the browser plugins seem to be much slower and less responsive with 4.1.x than they were with 4.0.x.

Most of my tests were working fine with 4.0.x, but with 4.1, and especially the changes to the object recognition algorithm, there seem to be some issues. But, again, they are intermittent and hard to nail down.
Shortcuts usually aren't...

MarkusT

Re: IE11 locking/crashing when repo object not found

Post by MarkusT » Tue Jan 07, 2014 11:31 am

Hello krstcs,

It would be great if you could provide us with a short example that shows this issue.
Otherwise, it's quite hard to reproduce it on our system.

We have changed the object recognition algorithm which might cause your issues.
Please try to change it to another mode (e.g. Reduce or Simple) for RanoreXPath generation mode in the 'Advanced tab' of the settings. Do you experience any difference if you do that?

Thanks in advance.

Regards,
Markus (T)

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: IE11 locking/crashing when repo object not found

Post by krstcs » Tue Jan 07, 2014 3:03 pm

Markus,

As I said, the issue is intermittent and I'm not exactly sure what the actual cause is, so I am not able to create a demonstration of the issue currently.

If I can nail down exactly what is causing it, I will send it to you.
Shortcuts usually aren't...

dochoa
Posts: 29
Joined: Tue Jul 16, 2013 11:36 pm

Re: IE11 locking/crashing when repo object not found

Post by dochoa » Fri Jan 22, 2016 7:29 pm

Hi Markus,

I believe I'm seeing this as well with 4.1.4.

The only other info I have is that shortly before IE crashes, open file dialog boxes render on screen as all black.

There is nothing in the Event Log of the system.

I will write more if I find it.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: IE11 locking/crashing when repo object not found

Post by Support Team » Mon Jan 25, 2016 4:11 pm

Hello dochoa,

A lot of improvements took place since Ranorex 4.1.4.
Therefore, I'd suggest updating to the latest version of Ranorex, 5.4.4.
More information about the latest bug fixes and changes can be found in the release notes.

If you need more information, please do let me know.

Sincerely,
Johannes
.
Image

dochoa
Posts: 29
Joined: Tue Jul 16, 2013 11:36 pm

Re: IE11 locking/crashing when repo object not found

Post by dochoa » Mon Feb 22, 2016 4:42 pm

Hello,

I have upgraded to 5.4.4

Still having a big issue, I have a test the iterates through 124 data rows.
I run it on a dedicated workstation.

Somewhere around 100 rows you can see Ranorex slow way down with long delays between actions.

Between each iteration I have Ranorex close and re-open Internet Explorer.
At the end I will have 11 IE windows open and I can't open the report (still in temp format and changing the file name does nothing, cannot see information).

There is nothing in the event logs at all.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: IE11 locking/crashing when repo object not found

Post by Support Team » Tue Feb 23, 2016 3:54 pm

Hello dochoa,

Thank you for upgrading Ranorex.

I’m afraid that your issue is not directly related to the initial issue mentioned within this thread. In order to analyze your issue in more detail, we would need further information about your test. I would be great if you could provide a sample solution which depicts the issue. If possible, please send this sample to [email protected]

Thank you in advance.

Sincerely,
Robert
.
Image