Image replacement issue

Ask general questions here.
965702
Posts: 14
Joined: Fri Dec 21, 2018 9:49 am

Image replacement issue

Post by 965702 » Mon Dec 09, 2019 4:07 pm

Hi Guys

I'm testing an ATC system and for some reason one of my screenshots will not allow me to replace the image direct from the report. I also try to update the screenshot via the module but I receive an error report.

The image in question has been updated with new buttons. I thought it may have been a storage issue but even when I slim down the project it still fails.

I've attached the error details and a snapshot of the object, any help appreciated.

Martin
Attachments
Image replace issue.txt
(4.03 KiB) Downloaded 2 times
Image issue Heathrow.rxsnp
(34.09 KiB) Downloaded 2 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 5459
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Image replacement issue

Post by odklizec » Tue Dec 10, 2019 7:25 am

Hi,

I'm afraid, I don't understand what exactly is your problem? Could you please post exact steps you are doing? Ideally, post entire Ranorex report and whole solution (ideally, a sample solution, with just one module showing the problem), where we can see the failing actions. Thanks.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

965702
Posts: 14
Joined: Fri Dec 21, 2018 9:49 am

Re: Image replacement issue

Post by 965702 » Tue Dec 10, 2019 11:33 am

Hi

I'm literally doing a screenshot update but the tool keeps crashing.

I've attached a screenshot of the error. I'm literally screenshot updating but the tool is now failing to do it. I can see Ranorex see the object with SPY.
Attachments
Image swap issue.JPG
Image swap issue.JPG (137.63 KiB) Viewed 46 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 5459
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Image replacement issue

Post by odklizec » Tue Dec 10, 2019 12:05 pm

Hi,

I can't reproduce anything like that. However, I'm already on 9.2.1, which appears to have fixed some screenshot creation-related bugs. Particularly this bug fix, could be related to your problem...
Fixed a bug where creating new validation screenshots with the image editor would not be possible if the new image was smaller than the existing one
So install 9.2.1 and try to reproduce your issue.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

965702
Posts: 14
Joined: Fri Dec 21, 2018 9:49 am

Re: Image replacement issue

Post by 965702 » Tue Dec 10, 2019 12:35 pm

Hi odklizec

I've just seen this in the release notes and will upgrade. Thanks again.