Infragistics WPF forms are not Identifying

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
kumarchowg
Posts: 19
Joined: Mon Jan 23, 2012 7:53 am

Infragistics WPF forms are not Identifying

Post by kumarchowg » Tue Sep 18, 2012 11:09 am

Hi,

will ranorex support Infragistics WPF forms. Does it require any implementation or is there any add on kind of thing

Thanks
Kumar

zator
Posts: 53
Joined: Wed Jul 04, 2012 1:44 pm
Location: Kraków, POLAND

Re: Infragistics WPF forms are not Identifying

Post by zator » Wed Sep 19, 2012 8:36 am

Hi Kumar,

I am working with customized Infragistics controls and i found some of them a bit problematic. However, for now all my problems were solved using code-modules and user-code-actions.

Paweł

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Infragistics WPF forms are not Identifying

Post by Support Team » Wed Sep 19, 2012 11:22 am

Hi,

You should be able to identify such elements with Ranorex, but in order to check if Ranorex fits all your needs I would suggest downloading the free trial version of Ranorex, here is the link: Free Trial.

Regards,
Markus
Ranorex Support Team
.
Image

kumarchowg
Posts: 19
Joined: Mon Jan 23, 2012 7:53 am

Re: Infragistics WPF forms are not Identifying

Post by kumarchowg » Tue Jan 29, 2013 7:22 am

hi there

We already have 3 licenses and we also tried with latest Ranorex version 4.X, where we saw that tool is unable to identify infragestics controls and the version of infragestics that is been done here in our organization is 12.0.1, can you please provide a possible solution for this to go ahead with automation.

Please let us know as we will be waiting for ur response.

Thanks
Kumar

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Infragistics WPF forms are not Identifying

Post by Support Team » Wed Jan 30, 2013 4:52 pm

Hi,

Could you please send us a Ranorex snapshot file of your application?
This will help use to analyze the issue.
Please also check if Microsoft Inspect, set to UIAutomation, is able to identify this elements.
If it is not able to identify them it seems that the UIAutomation implementation of the controls is not correct or missing. Are you using customized controls or standard Infragistics ones?

Regards,
Markus
.
Image

kumarchowg
Posts: 19
Joined: Mon Jan 23, 2012 7:53 am

Re: Infragistics WPF forms are not Identifying

Post by kumarchowg » Thu Jan 31, 2013 8:29 am

Hi Marcus

Thanks for the reply, please have a look at the ranorex screenshot of our application, we are trying to get the other information regarding setting in Microsoft inspect, please let us know if you can find something by these attached screenshot.

And do you have online support where we can sort out the problems quicker instead of posting it on Forum?

Please let us know how to get quicker response from Ranorex support apart from forum, something like a person helping out in skype or any other ways?

We will get back to you ASAP with developers response.

Thanks
Kumar
Attachments
Thirdscreen.rxsnp
Third Screen where infragestics controls are used
(678.66 KiB) Downloaded 183 times
Firstscreen.rxsnp
Second Screen where infragestics controls are used
(434.22 KiB) Downloaded 177 times
Secondscreen.rxsnp
First Screen where infragestics controls are used
(590.66 KiB) Downloaded 226 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Infragistics WPF forms are not Identifying

Post by Support Team » Thu Jan 31, 2013 11:17 am

Hi Kumar,

Thanks for the snapshots!

What is the "ProgressBar 'busyIndicator'" used for?
It seems that this control prevents Ranorex from tracking the elements behind.
Would it be possible to disable this ProgressBar or to resize it for test purposes, because it has nearly the same size (1280; 962 ) as the main form itself.
If you are already a customer you can send us an email to our support mail address and we could for instance schedule a web meeting.
In general we are trying to answer the questions as soon as possible whether it is posted in forum or send to our mail address.
We are typically responding within 24 hours which is a quite fast response time.

Regards,
Markus
.
Image