Instrumentation success but could not start apps

Mobile Testing, Android App Testing.
xsun
Posts: 3
Joined: Fri Sep 28, 2012 7:21 pm

Instrumentation success but could not start apps

Post by xsun » Fri Sep 28, 2012 7:34 pm

Hello,

I have instrumented app, but error occurs when I am starting app in the studio, it says : "Failed to start because no app started event received.",

Here are the apk files before instrumentation and after.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Instrumentation success but could not start apps

Post by Support Team » Mon Oct 01, 2012 4:22 pm

Hello,

I cannot find the APK files. Would you please upload it again.

Regards,
Bernhard
Ranorex Support Team
.
Image

xsun
Posts: 3
Joined: Fri Sep 28, 2012 7:21 pm

Re: Instrumentation success but could not start apps

Post by xsun » Mon Oct 01, 2012 6:26 pm

Here is the apk file. Thanks,
Attachments
clevest.mobile.smartdeviceapp-Signed.rar
(2.36 MiB) Downloaded 244 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Instrumentation success but could not start apps

Post by Support Team » Tue Oct 02, 2012 12:15 pm

Hello,

Thank you for the APK file. We will take a look into this issue and get back to you as soon as possible. The related developer is out of office this week, so it might take a little longer.

Regards,
Bernhard
Ranorex Support Team
.
Image

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Instrumentation success but could not start apps

Post by Support Team » Wed Oct 03, 2012 1:44 pm

Hello,

We looked at the issue. Unfortunately it is not possible to make android web tests at the moment. We are working on this issue and will add this feature in one of our next releases. You can try to make the instrumentation with Source Code, but we can not guarantee that it works.

Regards,
Bernhard
Ranorex Support Team
.
Image

dc_alina
Posts: 8
Joined: Wed Sep 19, 2012 7:39 am

Re: Instrumentation success but could not start apps

Post by dc_alina » Sat Oct 13, 2012 8:01 pm

Hi

I'm having same issue when trying to use Ranorex for Skype on android - Instrumentation says is succesfull, but can not start afterwords.
I'm using Ranorex 3.3.2, Android SDK emulator and same result on my phone - Samsung Galaxy.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Instrumentation success but could not start apps

Post by Support Team » Mon Oct 15, 2012 12:20 pm

Hello,

Could you please send us the APK file? There are many APK's for Skype available. We don't know which one you are using. Which version of Android do you use?
Thank you!

Regards,
Bernhard
Ranorex Support Team
.
Image

dc_alina
Posts: 8
Joined: Wed Sep 19, 2012 7:39 am

Re: Instrumentation success but could not start apps

Post by dc_alina » Mon Oct 15, 2012 3:18 pm

Hi

tried with several Skype apk files from internet. Attached one of them.
(tried several times to attach the file and won't include it - IE nor Mozilla)

Thanks,
Alina

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Instrumentation success but could not start apps

Post by Support Team » Tue Oct 16, 2012 7:38 am

Hello Alina,

You can also send the APK file to [email protected]. If the file is too big, please contact me again and I will send you the access data for our ftp server via e-mail.

Regards,
Bernhard
Ranorex Support Team
.
Image

dc_alina
Posts: 8
Joined: Wed Sep 19, 2012 7:39 am

Re: Instrumentation success but could not start apps

Post by dc_alina » Tue Oct 16, 2012 12:13 pm

Hi

Sent email to one of your reprezentatives and I understand he FRW to you.
Version of Android that I've used 2.2.1 - phone model GT-S5570, and emulator - latest Android SDK.

Thanks

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Instrumentation success but could not start apps

Post by Support Team » Wed Oct 17, 2012 5:15 pm

Hello,

Thank you for the files. We tested both APKs. The 'GO Contacts.apk' works without problems, but the APK from Skype doesn't work. This is an issue of building the resources. Unfortunately there is no way to fix it. One way would be to instrument the APK with Source Code, but I'm afraid that you need the sources to do so.

Regards,
Bernhard
Ranorex Support Team
.
Image

dc_alina
Posts: 8
Joined: Wed Sep 19, 2012 7:39 am

Re: Instrumentation success but could not start apps

Post by dc_alina » Thu Oct 18, 2012 10:57 am

Hi

Can you name an apk that I can use for a Ranorex - android demo that really works? (except KeePass application) tried several ones - and if intrumentation is succesfull then, it won't reccognize the actions - that was the case for GoContacts (can not use Ranorex to automate adding contacts action).

Thank you

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Instrumentation success but could not start apps

Post by Support Team » Fri Oct 19, 2012 4:19 pm

Hello,

You could, e.g. try the apk from the MoneyManager app. This is an app we use for demos too.

Regards,
Bernhard
Rnaorex Support Team
.
Image

dc_alina
Posts: 8
Joined: Wed Sep 19, 2012 7:39 am

Re: Instrumentation success but could not start apps

Post by dc_alina » Mon Oct 22, 2012 8:32 am

Hi

can you please post a link to the apk that you've mentioned? or send the file? just to make sure I'll be using same application.

Thanks

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Instrumentation success but could not start apps

Post by Support Team » Mon Oct 22, 2012 3:08 pm

Hello,

You should have received an e-mail with the attached APK file.

Regards,
Bernhard
Ranorex Support Team
.
Image