Instrumented iOS app crashes when launching

Mobile Testing, Android App Testing.
ceeteehtx
Posts: 1
Joined: Tue Mar 30, 2021 4:56 pm

Instrumented iOS app crashes when launching

Post by ceeteehtx » Wed Mar 31, 2021 3:53 pm

Hello!

We have been using the instrumentation wizard for some time now to install our iOS apps to multiple devices.
Recently, every device will have the app crash upon launching, both when launching the app by tapping the icon from the iOS home screen, as well as when trying to launch it from the RxServiceApp.

Our workflow is:
1) App devs deploy code to a build server where it is built and signed for testing and eventual distribution
2) We download the built and signed .ipa file from the build server
3) We instrument the app onto our devices through Ranorex for automated testing

This has been working for sometime until very recently, when all of our apps across all devices will no longer open using this method.
This all started happening when we renewed our Apple certification and distribution profiles.
We refreshed the certs/profiles in the exact same manner we have been doing for years.
Ranorex Instrumentation wizard does not complain about invalid cert/profile, and successfully signs and deploys the instrumented apps to the devices.
Installing the regular un-instrumented build directly from our build server opens without issue.

Currently, we are using the source build method of compiling with the automation library as a stop-gap. It works and will successfully launch and run automated testing, but this is not a maintainable workflow due to the amount of devices we test on.

Here is the crash log from Apple console (app bundle name censored out):

Launch failed with Error Domain=NSPOSIXErrorDomain Code=85 "Bad executable (or shared library)" UserInfo={NSLocalizedDescription=Launchd job spawn failed with error: 85}
Bootstrapping failed for <FBApplicationProcess: 0x107e917b0; application<com.******.*******.*******>:<invalid>> with error: <NSError: 0x2803758f0; domain: RBSRequestErrorDomain; code: 5; reason: "Launch failed."> {
underlyingError = <NSError: 0x280376970; domain: NSPOSIXErrorDomain; code: 85>;
}

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6557
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Instrumented iOS app crashes when launching

Post by odklizec » Wed Apr 07, 2021 8:45 am

Hi,

I'm afraid, there is number of missing details in your post. Please answer these:
Ranorex version? (most recent is 9.5.0)
iOS version?
Are you sure the ipa file is not obfuscated?
And finally, have you tried to instrument your iOS app via code (ask devs to do that for you).

My best guess why it worked before and why it does not work now is, that the app is compiled with most recent iOS version and your Ranorex version is not updated yet? So it may not support instrumenting your IPA or does not instrument it properly?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration