InvokeRemotly on .net2 DLLs

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
Tnimni
Posts: 49
Joined: Thu Jan 02, 2014 4:03 pm

InvokeRemotly on .net2 DLLs

Post by Tnimni » Wed Apr 16, 2014 4:11 pm

Hi,

I have a Ranorex project that is complied to .net 4.

The AUT has 2 versions, 1 version is complied to .net 4 and works very well with Ranorex.

The other version is complied to .net 2 and doesn't work that well with Ranorex.

we have many custom control derived from DevExpress, i'm trying to interact with them using InvokeRemotly,

this seems to be working very well with .net 4, however when trying to interact with .net 2 version i get errors.

I know i need to InvokeRemotly from the same or LOWER version of .net, meaning i need my Ranorex project to run under .net 2.

problem is Ranorex project requires a minimum of .net 3.5 otherwise it throws error about Ranorex.Plugin.xx

any ideas?

Regards,

Tsachi

Tnimni
Posts: 49
Joined: Thu Jan 02, 2014 4:03 pm

Re: InvokeRemotly on .net2 DLLs

Post by Tnimni » Fri Apr 18, 2014 8:48 pm

Hi,

Please find the attached response from Ranorex support team (that answered a while back to someone else than me): http://www.ranorex.com/forum/devexpress ... tml#p14137

it states that "Your System Under Test has to have a Target .NET Framework greater than or equal to the testing project."

Unless somthing changed since than, it is still true since i tried it several times and it DOES NOT work.

Regards,

Tsachi

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: InvokeRemotly on .net2 DLLs

Post by Support Team » Wed Apr 23, 2014 1:33 pm

Hello Tnimni,

I’m sorry I mixed up something. Please try to compile your test suite with Microsoft .NET Framework v 3.0. The base framework of .NET Framework v2.0, 3.0 and 3.5 is the same so there shouldn’t be any issues. Please let me know if you can resolve your issue using .NET Framework 3.

Regards,
Robert
.
Image

Tnimni
Posts: 49
Joined: Thu Jan 02, 2014 4:03 pm

Re: InvokeRemotly on .net2 DLLs

Post by Tnimni » Wed Apr 23, 2014 3:02 pm

Support Team wrote:Hello Tnimni,

I’m sorry I mixed up something. Please try to compile your test suite with Microsoft .NET Framework v 3.0. The base framework of .NET Framework v2.0, 3.0 and 3.5 is the same so there shouldn’t be any issues. Please let me know if you can resolve your issue using .NET Framework 3.

Regards,
Robert
Hi,

I have already done that with 3.5 and it works fine, beside the point that i had to use the - attach to process... option because i run it from nUnit, when i select .net2 runtime inside nUnit it will not stop on break points unless you attach Ranorex studio to the process :)

maybe you can add that tip to the FAQ

Kind regards

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: InvokeRemotly on .net2 DLLs

Post by Support Team » Fri Apr 25, 2014 1:04 pm

Hello Tnimni,

I'm glad that you could resolve your issue and thank you for the hint!

Regards,
Robert
.
Image