iOS 7 Automation is very slow

Mobile Testing, Android App Testing.
TSEGAH
Posts: 1
Joined: Wed Sep 10, 2014 8:31 am

iOS 7 Automation is very slow

Post by TSEGAH » Wed Sep 10, 2014 9:47 am

Hello,

I'm currently evaluating Ranorex and I really like the tool and the features but I'm experiencing some problems when i run the test cases.

I write basic functions in code then I build up more complex stpes like:
1. Function: Open a modal window
2. Function: Fill in textfield on modal window
3. Function: Press OK button on modal window
I. Step: 1+2+3 functions

The exact rxpaths are: (no wildcards or dynamic objects)
form/container[4]/container[1]/container[2]/text
form/container[4]/container[1]/container[1]/button[@accessibilitylabel='OK']

Results:
All function runs very slow on iOS. I have to wait 3-4 seconds to press a single button, or fill in the input field. The instrumented app is also very slow when I use it manually. (The non instrumented version runs smoothly)
i Also tried without attached debugger.
On iOS it runs about 9 sec and the same test runs on Android about 3-4 sec and 1-2 sec on Win8.

My question:
This is normal on iOS or it should be faster?

PS: Because of my company rules I'm not able to send the source of the project

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: iOS 7 Automation is very slow

Post by Support Team » Fri Sep 12, 2014 1:56 pm

Hello TSEGAH,

Unfortunately, it is very difficult to give an estimation about response time for automated actions since it highly varies from app to app. May I ask you to contact [email protected] in order to analyze the issue in more detail? It would be great if you could provide your application or even better the XCode project to us, if that is possible for you.

Thanks,
Robert
.
Image