iOS app instrumentation fails

Mobile Testing, Android App Testing.
gab
Posts: 1
Joined: Wed Jan 08, 2020 1:51 am

iOS app instrumentation fails

Post by gab » Wed Jan 08, 2020 2:45 am

Hi there, I am getting the following errors when attempting to use the Ranorex Instrumentation Wizard on our iOS app.
instrumentation error.png
instrumentation error.png (6.4 KiB) Viewed 232 times
And clicking details reveals this:
System.OutOfMemoryException: Exception of type 'System.OutOfMemoryException' was thrown.
at System.IO.MemoryStream.set_Capacity(Int32 value)
at System.IO.MemoryStream.EnsureCapacity(Int32 value)
at System.IO.MemoryStream.Write(Byte[] buffer, Int32 offset, Int32 count)
at System.IO.BinaryWriter.Write(Byte[] buffer)
at Ranorex.Plugin.Mobile.Tools.Ios.Instrumentation.MachOReaderWriter.Save(BinaryWriter writer)
at Ranorex.Plugin.Mobile.Tools.Ios.Instrumentation.IosInstrumentation.AddDylibMachOHeader(Byte[] mainBinaryData, String dylibName)
at Ranorex.Plugin.Mobile.Tools.Ios.Instrumentation.IosInstrumentation.StartInstrumentation()
at Ranorex.Plugin.Mobile.Tools.Ios.IosToolRunner.Instrument(IIosOptions options, Action`2 progressCallback, String& instrumentedIpaPath)
at Ranorex.Plugin.Mobile.Tools.Ios.IosToolRunner.InstrumentInternal(IOptions options, Action`2 progressCallback, Action`1 msgCallback)
at Ranorex.Plugin.Mobile.Tools.Ios.IosToolRunner.Instrument(IOptions options, Action`2 progressCallback, Action`1 msgCallback)
at Ranorex.Plugin.Mobile.RxIntegration.Instrumentation.IosWorker.Run()
at Ranorex.Controls.Instrumentation.IosResultPage.bgw_DoWork(Object sender, DoWorkEventArgs e)

I'm unable to pin down the issue;
- I'm using an iPad Mini 2, I've tried instrumenting with it on iOS 11.4.1 and iOS 12.4.4 with the same result.
- The iPad has plenty (46gb) of free storage.
- The IPA file is not a backup from the App Store (it was built with Expo)
- The IPA was not already instrumented with static Ranorex lib.
- The IPA definitely supports the device architecture.

Any help with this would be great

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6162
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: iOS app instrumentation fails

Post by odklizec » Wed Jan 08, 2020 8:10 am

Hi,

At first, are you using most recent Ranorex 9.2.1? If not, please update Ranorex and try to instrument your app again. If the problem appears also in 9.2.1, I would suggest to contact Ranorex support, via support form available here:
https://www.ranorex.com/support-query/
This kind of issue is usually not solvable via forum and without examining the problematic app.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration