iOS-Button made visible by App is invisible for Ranorex

Mobile Testing, Android App Testing.
Patrick Hollerbach
Posts: 21
Joined: Thu Jan 02, 2014 4:00 pm

iOS-Button made visible by App is invisible for Ranorex

Post by Patrick Hollerbach » Mon Jan 12, 2015 9:05 am

Hello and happy new year,

we have a problem with one of our automated apps since we updated to Ranorex 5.2.1.

We have an app which runs in landscape mode. In this app we have 2 buttons for navigating forwards and backwards. When navigating to an other page, the navigation-buttons are initially visible, then an action change the visbility to false during an animation ist running and after it finished an other action is called to make the buttons visible again.
We used some usercode to wait until the navigation button is visible. It worked until Ranorex 5.2.1. After updating to Ranorex 5.2.1, ranorex always shows that the visible-property is false while the button is shown. We also tried to use the WaitForExist() method from Ranorex and added the attribute "@visible=true" at our navigation-buttons RxPath but it doesn't work either. Then we tried to access the button via host.local.find() but the result was the same - the visible-property ranorex reads is still false.
When we inspect the button in ranorex spy, it is shown as "visible = false".

Our test-environment:
Ranorex Studio 5.2.1.20895
iOS-Agent: libRxAutomationUni v1.7.1
iOS-Device: iPad3
iOS-Version: iOS 8.1.1

Do you have any idea what can be the problem?

Regards,
Patrick

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: iOS-Button made visible by App is invisible for Ranorex

Post by Support Team » Tue Jan 13, 2015 12:54 pm

Happy new Year Patrick,

Unfortunately we are not aware of such an issue. May I ask you to send a snapshot of your application under test to [email protected]
This will allow us to analyze the specific element in more detail.

Thank you in advance.

Regards,
Markus (S)
.
Image