IOS Element does not have detailed object info.

Mobile Testing, Android App Testing.
topcatalpha
Posts: 47
Joined: Tue Sep 06, 2011 7:48 am

IOS Element does not have detailed object info.

Post by topcatalpha » Tue May 21, 2013 3:02 pm

Hi,

i have an app running and connected with ranorex (lib) and can record my actions on the iphone (using wifi).

When a playback, some of the elements are not known and playback fails.
So i tried to find the objects using the spy and found out that i have some elements calling : IosElement without any further objects.

The element does have 4 buttons, but they are not visible in the spy.
Can someone give me a tip how i can find them ?

regards,

Kurt
Attachments
screenshot_IOS.png
screenshot_IOS.png (20.96 KiB) Viewed 1002 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: IOS Element does not have detailed object info.

Post by Support Team » Wed May 22, 2013 3:13 pm

Hello,

I can see that there are many objects with the name IosElement in your image.
Is it possible to post a Ranorex snapshot file in order to analyze the issue in more detail?
Are you using some third party controls in your app?
Thank you!

Regards,
Bernhard
.
Image

JToelstede
Posts: 55
Joined: Fri May 24, 2013 12:57 pm

Re: IOS Element does not have detailed object info.

Post by JToelstede » Fri May 24, 2013 1:41 pm

Hi Kurt,

I had a similar problem with labes in my app. In my case I forgot to set the accessebility labels for each label in my ios-app and all the labels had the same name in ranorex spy. I know that other testing tools craches if there are bunch of same elements in one view without setting the accessebility label.

Regards,
Joerg