iOS: missing header sections in a grouped table view

Bug reports.
JToelstede
Posts: 55
Joined: Fri May 24, 2013 12:57 pm

iOS: missing header sections in a grouped table view

Post by JToelstede » Tue Mar 25, 2014 11:56 am

After the update from Ranorex 4.0.5 to 5.0.1 it isn't possible to read the text of an header section in a grouped table.
I used "View Spy" to verify if something changed in our app but i couldn't find the header section elements in the overview.
The value of the attribute "NumOfSections" of the iOS table is "1" in View Spy.

I use Ranorex 5.0.1 with the libRxAutomationUni_150.a.
The test device is an iPad with iOS 7.0.6.
After the update from Ranorex 4.0.5 to 5.0.1 I rebooted my computer.

Thanks for help.

Best regards,
Joerg

JToelstede
Posts: 55
Joined: Fri May 24, 2013 12:57 pm

Re: iOS: missing header sections in a grouped table view

Post by JToelstede » Wed Mar 26, 2014 7:43 am

Hi,

today I mad an other test to that problem.
I installed an older version of our AUT which contains the previous agent of the ranorex version 4.0.5.
The header sections of our grouped table are available and they are also visible in View Spy.

Best regards
Joerg

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3914
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: iOS: missing header sections in a grouped table view

Post by odklizec » Wed Mar 26, 2014 8:09 am

Hi Joerg,

I would suggest you to send the support a snapshot taken both from 4.0.5 and 5.0.1 instrumented app. They can't do much without seeing the problem. I too experienced a problem with Rx 5.0 and comparative snapshot from 4.x and 5.0 helped them to find the problem very quickly.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration